package/gawk: add optional support for libsigsegv
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 21 Feb 2016 17:34:57 +0000 (18:34 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Feb 2016 20:28:45 +0000 (21:28 +0100)
When libsigsegv was compiled before, gawk will use it as optional
dependency:

$ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/bin/gawk | grep NEEDED
  0x0000000000000001 (NEEDED)             Shared library: [libsigsegv.so.2]
[...]

The build system offers no option to en-/disable libsigsegv support:
http://git.savannah.gnu.org/cgit/gawk.git/tree/m4/libsigsegv.m4

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gawk/gawk.mk

index 507ea6de6fa5c0879f9da57f7fd5beceeecf3429..da9be95cd07fe2970f1552009b9b64f006852b31 100644 (file)
@@ -16,6 +16,10 @@ ifeq ($(BR2_PACKAGE_BUSYBOX),y)
 GAWK_DEPENDENCIES += busybox
 endif
 
+ifeq ($(BR2_PACKAGE_LIBSIGSEGV),y)
+GAWK_DEPENDENCIES += libsigsegv
+endif
+
 # --with-mpfr requires an argument so just let
 # configure find it automatically
 ifeq ($(BR2_PACKAGE_MPFR),y)