package/wpebackend-fdo: new package
authorFrancois Perrad <fperrad@gmail.com>
Tue, 5 Feb 2019 20:41:50 +0000 (21:41 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 11 Feb 2019 20:45:44 +0000 (21:45 +0100)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Reviewed-by: Adrian Perez de Castro <aperez@igalia.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/wpebackend-fdo/Config.in [new file with mode: 0644]
package/wpebackend-fdo/wpebackend-fdo.hash [new file with mode: 0644]
package/wpebackend-fdo/wpebackend-fdo.mk [new file with mode: 0644]

index 50e4ffe6a9736a971d972ba148da80089aa11f6d..f5d302d286160a7d4461248f1042ad99605565e7 100644 (file)
@@ -71,6 +71,7 @@ F:    package/libepoxy/
 F:     package/libwpe/
 F:     package/webkitgtk/
 F:     package/woff2/
+F:     package/wpebackend-fdo/
 
 N:     Adrien Gallouët <adrien@gallouet.fr>
 F:     package/bird/
@@ -847,6 +848,7 @@ F:  package/qemu/
 F:     package/sdl2_mixer/
 F:     package/sdl2_net/
 F:     package/tekui/
+F:     package/wpebackend-fdo/
 F:     package/wsapi-fcgi/
 F:     package/wsapi-xavante/
 F:     utils/scancpan
index 84ccb0358f1511d7d94805e2322a0a2f3c1ced2c..61ae22db0240e0ac534377c5fccfd9e0bb888eb5 100644 (file)
@@ -1321,6 +1321,7 @@ menu "Graphics"
        source "package/webkitgtk/Config.in"
        source "package/webp/Config.in"
        source "package/woff2/Config.in"
+       source "package/wpebackend-fdo/Config.in"
        source "package/zbar/Config.in"
        source "package/zxing-cpp/Config.in"
 endmenu
diff --git a/package/wpebackend-fdo/Config.in b/package/wpebackend-fdo/Config.in
new file mode 100644 (file)
index 0000000..2f5f965
--- /dev/null
@@ -0,0 +1,19 @@
+comment "wpebackend-fdo needs a toolchain w/ C++, wchar, threads, dynamic library and an OpenEGL-capable backend"
+       depends on !BR2_PACKAGE_HAS_LIBEGL || !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR \
+               || !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS
+
+config BR2_PACKAGE_WPEBACKEND_FDO
+       bool "wpebackend-fdo"
+       depends on !BR2_STATIC_LIBS # wayland
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_TOOLCHAIN_HAS_THREADS # wayland, libglib2
+       depends on BR2_USE_WCHAR # libglib2
+       depends on BR2_USE_MMU # libglib2
+       depends on BR2_PACKAGE_HAS_LIBEGL
+       select BR2_PACKAGE_LIBGLIB2
+       select BR2_PACKAGE_LIBWPE
+       select BR2_PACKAGE_WAYLAND
+       help
+         WPEBackend interface using freedesktop.org API.
+
+         https://wpewebkit.org/
diff --git a/package/wpebackend-fdo/wpebackend-fdo.hash b/package/wpebackend-fdo/wpebackend-fdo.hash
new file mode 100644 (file)
index 0000000..20c89d3
--- /dev/null
@@ -0,0 +1,7 @@
+# From https://wpewebkit.org/releases/wpebackend-fdo-1.0.0.tar.xz.sums
+md5 5318728afb3bf7417293af67ce427963 wpebackend-fdo-1.0.0.tar.xz
+sha1 7ee22bc1d585616f4ad2047d8be54ec396486211 wpebackend-fdo-1.0.0.tar.xz
+sha256 7a747f87a1ae46d30144369050e3ce348b58986d04e1a139ba75c198fa636729 wpebackend-fdo-1.0.0.tar.xz
+
+# Hashes for license files:
+sha256 c9f6803371047fad3e72200ec6cd226329a5ee08ac61104c8211c2761fb46825 COPYING
diff --git a/package/wpebackend-fdo/wpebackend-fdo.mk b/package/wpebackend-fdo/wpebackend-fdo.mk
new file mode 100644 (file)
index 0000000..06c87cb
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# wpebackend-fdo
+#
+################################################################################
+
+WPEBACKEND_FDO_VERSION = 1.0.0
+WPEBACKEND_FDO_SITE = https://wpewebkit.org/releases
+WPEBACKEND_FDO_SOURCE = wpebackend-fdo-$(WPEBACKEND_FDO_VERSION).tar.xz
+WPEBACKEND_FDO_INSTALL_STAGING = YES
+WPEBACKEND_FDO_LICENSE = BSD-2-Clause
+WPEBACKEND_FDO_LICENSE_FILES = COPYING
+WPEBACKEND_FDO_DEPENDENCIES = libglib2 libwpe wayland
+
+$(eval $(cmake-package))