qt: disable precompiled headers when ccache is enabled
authorMichael Roth <mroth@nessie.de>
Wed, 7 Oct 2009 09:20:39 +0000 (11:20 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 9 Oct 2009 12:54:27 +0000 (14:54 +0200)
ccache and precompiled headers don't work together, so disable
precompiled headers when ccache is enabled.

The benefit of ccache compiling Qt a second or more time is much
higher than the costs of disabled precompiled headers in the first run.

Signed-off-by: Michael Roth <mroth@nessie.de>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qt/qt.mk

index 37849f98b9206622f628bd5525a91d7a6f123673..ae03fa6843e5d4df5f5327552feae5019ab92645 100644 (file)
@@ -315,6 +315,11 @@ else
 QT_CONFIGURE+= -no-stl
 endif
 
+# ccache and precompiled headers don't play well together
+ifeq ($(BR2_CCACHE),y)
+QT_CONFIGURE += -no-pch
+endif
+
 BR2_PACKAGE_QT_EMB_PLATFORM:=$(call qstrip,$(BR2_PACKAGE_QT_EMB_PLATFORM))
 
 # Figure out what libs to install in the target