python-html5lib: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Wed, 13 Jan 2016 15:18:10 +0000 (16:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 13 Jan 2016 20:35:08 +0000 (21:35 +0100)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/python-html5lib/Config.in [new file with mode: 0644]
package/python-html5lib/python-html5lib.hash [new file with mode: 0644]
package/python-html5lib/python-html5lib.mk [new file with mode: 0644]

index 06ed4a8227f553b13f3d9ad70bdd3e0253ad20d6..89b23dbfe3606d033595464794b39e8ff0a6f8d9 100644 (file)
@@ -638,6 +638,7 @@ menu "External python modules"
        source "package/python-flask/Config.in"
        source "package/python-flup/Config.in"
        source "package/python-gobject/Config.in"
+       source "package/python-html5lib/Config.in"
        source "package/python-httplib2/Config.in"
        source "package/python-id3/Config.in"
        source "package/python-idna/Config.in"
diff --git a/package/python-html5lib/Config.in b/package/python-html5lib/Config.in
new file mode 100644 (file)
index 0000000..c3e9f2a
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PYTHON_HTML5LIB
+       bool "python-html5lib"
+       help
+         HTML parser based on the WHATWG HTML specification.
+
+         https://github.com/html5lib/html5lib-python
diff --git a/package/python-html5lib/python-html5lib.hash b/package/python-html5lib/python-html5lib.hash
new file mode 100644 (file)
index 0000000..0ec712a
--- /dev/null
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi?:action=show_md5&digest=ef43cb05e9e799f25d65d1135838a96f, sha256 locally computed
+md5     ef43cb05e9e799f25d65d1135838a96f  html5lib-0.9999999.tar.gz
+sha256  2612a191a8d5842bfa057e41ba50bbb9dcb722419d2408c78cff4758d0754868  html5lib-0.9999999.tar.gz
diff --git a/package/python-html5lib/python-html5lib.mk b/package/python-html5lib/python-html5lib.mk
new file mode 100644 (file)
index 0000000..93eef9a
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-html5lib
+#
+################################################################################
+
+PYTHON_HTML5LIB_VERSION = 0.9999999
+PYTHON_HTML5LIB_SOURCE = html5lib-$(PYTHON_HTML5LIB_VERSION).tar.gz
+PYTHON_HTML5LIB_SITE = https://pypi.python.org/packages/source/h/html5lib
+PYTHON_HTML5LIB_LICENSE = MIT
+PYTHON_HTML5LIB_LICENSE_FILES = LICENSE
+PYTHON_HTML5LIB_SETUP_TYPE = distutils
+
+$(eval $(python-package))