fluxbox: install session file unconditionally
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Nov 2014 14:18:50 +0000 (15:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 23:27:58 +0000 (00:27 +0100)
As discussed, users should use a rootfs overlay or a post-build script
instead of a custom skeleton to override files installed by Buildroot,
so there is no point in having conditions when installing init scripts
or configuration files.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/fluxbox/fluxbox.mk

index 21901d619b608ab3cf5303348f63f84b913d4356..a0f93672effc3780f0b4bdeac8f4d31b5ccb6a52 100644 (file)
@@ -24,8 +24,8 @@ FLUXBOX_CONF_OPTS += --disable-imlib2
 endif
 
 define FLUXBOX_INSTALL_XSESSION_FILE
-       [ -f $(TARGET_DIR)/root/.xsession ] || $(INSTALL) -m 0755 -D \
-               package/fluxbox/xsession $(TARGET_DIR)/root/.xsession
+       $(INSTALL) -m 0755 -D package/fluxbox/xsession \
+               $(TARGET_DIR)/root/.xsession
 endef
 
 FLUXBOX_POST_INSTALL_TARGET_HOOKS += FLUXBOX_INSTALL_XSESSION_FILE