Add on2-8170 kernel modules
authorAlexandre Belloni <alexandre.belloni@free-electrons.com>
Tue, 11 Jun 2013 10:18:39 +0000 (12:18 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 15 Jun 2013 21:12:48 +0000 (23:12 +0200)
Signed-off-by: Alexandre Belloni <alexandre.belloni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/on2-8170-modules/Config.in [new file with mode: 0644]
package/on2-8170-modules/on2-8170-modules.mk [new file with mode: 0644]

index b23da7588616ed2c595763a5b3f1dd823b76eb58..fa64426785905bd3c07cf99479efcfc67a6841d1 100644 (file)
@@ -272,6 +272,7 @@ source "package/minicom/Config.in"
 source "package/nanocom/Config.in"
 source "package/neard/Config.in"
 source "package/ofono/Config.in"
+source "package/on2-8170-modules/Config.in"
 source "package/open2300/Config.in"
 source "package/openocd/Config.in"
 source "package/owl-linux/Config.in"
diff --git a/package/on2-8170-modules/Config.in b/package/on2-8170-modules/Config.in
new file mode 100644 (file)
index 0000000..18c066e
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_ON2_8170_MODULES
+       bool "on2-8170 modules"
+       depends on BR2_LINUX_KERNEL
+       depends on BR2_arm926t
+       help
+         Kernel modules for Hantro x170 hardware video decompression support.
+
+         http://www.at91.com/linux4sam/bin/view/Linux4SAM/SAM9M10Gstreamer
+
+comment "on2-8170 modules requires a linux kernel to be built"
+       depends on !BR2_LINUX_KERNEL
diff --git a/package/on2-8170-modules/on2-8170-modules.mk b/package/on2-8170-modules/on2-8170-modules.mk
new file mode 100644 (file)
index 0000000..800abc7
--- /dev/null
@@ -0,0 +1,23 @@
+################################################################################
+#
+# on2-8170-modules
+#
+################################################################################
+
+ON2_8170_MODULES_VERSION = 73b0806
+ON2_8170_MODULES_SITE    = http://github.com/alexandrebelloni/on2-8170-modules/tarball/$(ON2_8170_MODULES_VERSION)
+
+ON2_8170_MODULES_DEPENDENCIES = linux
+
+ON2_8170_MODULES_LICENSE = GPLv2+
+#There is no license file
+
+define ON2_8170_MODULES_BUILD_CMDS
+       $(MAKE) -C $(LINUX_DIR) $(LINUX_MAKE_FLAGS) M=$(@D)
+endef
+
+define ON2_8170_MODULES_INSTALL_TARGET_CMDS
+       $(MAKE) -C $(LINUX_DIR) $(LINUX_MAKE_FLAGS) M=$(@D) modules_install
+endef
+
+$(eval $(generic-package))