fix broken libpng compile -- malloc was being handled incorrectly
authorEric Andersen <andersen@codepoet.org>
Sat, 8 Jul 2006 23:56:47 +0000 (23:56 -0000)
committerEric Andersen <andersen@codepoet.org>
Sat, 8 Jul 2006 23:56:47 +0000 (23:56 -0000)
when cross compiling

package/libpng/libpng.mk

index b8e90843de220c7993a6ed18b3d343f03c6b0c6d..7ea0e615d6d013874d535cc619958cde825bee0f 100644 (file)
@@ -41,6 +41,12 @@ $(LIBPNG_DIR)/.configured: $(LIBPNG_DIR)/.unpacked
                $(TARGET_CONFIGURE_OPTS) CC_FOR_BUILD="$(HOSTCC)" \
                CFLAGS="$(TARGET_CFLAGS)" \
                ./configure \
+               ac_cv_func_memcmp_working=yes \
+               ac_cv_have_decl_malloc=yes \
+               gl_cv_func_malloc_0_nonnull=yes \
+               ac_cv_func_malloc_0_nonnull=yes \
+               ac_cv_func_calloc_0_nonnull=yes \
+               ac_cv_func_realloc_0_nonnull=yes \
                --target=$(GNU_TARGET_NAME) \
                --host=$(GNU_TARGET_NAME) \
                --build=$(GNU_HOST_NAME) \