For now, mimic arm behavior for armeb since that's what uClibc's
authorManuel Novoa III <mjn3@codepoet.org>
Fri, 3 Sep 2004 01:24:18 +0000 (01:24 -0000)
committerManuel Novoa III <mjn3@codepoet.org>
Fri, 3 Sep 2004 01:24:18 +0000 (01:24 -0000)
fix-includes script winds up doing.  Fix this later...

make/kernel-headers.mk

index 921b08cf95327b6d0dc9ac32ac641154fc55fe2e..0eb2035fcad32edac380fd7160d9dac20b16e44c 100644 (file)
@@ -81,6 +81,12 @@ $(LINUX_DIR)/.configured: $(LINUX_DIR)/.patched
             if [ ! -L proc ] ; then \
             ln -fs proc-armv proc; \
             ln -fs arch-ebsa285 arch; fi); \
+       elif [ "$(ARCH)" = "armeb" ];then \
+           (cd $(LINUX_DIR)/include; ln -fs asm-arm$(NOMMU) asm; \
+            cd asm; \
+            if [ ! -L proc ] ; then \
+            ln -fs proc-armv proc; \
+            ln -fs arch-ebsa285 arch; fi); \
        elif [ "$(ARCH)" = "cris" ];then \
            (cd $(LINUX_DIR)/include; ln -fs asm-cris asm;) \
        else \