lua: make sure that CFLAGS are passed
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 22 Aug 2010 06:01:55 +0000 (08:01 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 24 Aug 2010 13:05:19 +0000 (15:05 +0200)
We were passing a custom MYCFLAGS value to Lua's Makefile, but because
of $(TARGET_CONFIGURE_OPTS), we were also passing a CFLAGS variable,
which was overriding Lua's internal CFLAGS variable. The result was
that MYCFLAGS wasn't taken into account.

Extracted from the patch proposed by François Perrad in bug #2353.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lua/lua.mk

index d66be9fd3ce8afe71e0c2e11ffc85de6e9913cbd..598eea140cb0221425666c8a1795a1b82634a930 100644 (file)
@@ -24,7 +24,9 @@ endif
 define LUA_BUILD_CMDS
        sed -i -e 's/-O2//' $(@D)/src/Makefile
        sed -i -e 's/\/usr\/local/\/usr/' $(@D)/etc/lua.pc
-       $(MAKE) $(TARGET_CONFIGURE_OPTS) MYCFLAGS="$(LUA_MYCFLAGS)" \
+       $(MAKE) \
+       CC="$(TARGET_CC)" RANLIB="$(TARGET_RANLIB)" \
+       MYCFLAGS="$(TARGET_CFLAGS) $(LUA_MYCFLAGS)" \
        MYLIBS="$(LUA_MYLIBS)" AR="$(TARGET_CROSS)ar rcu" \
        PKG_VERSION=$(LUA_VERSION) -C $(@D)/src all
 endef