package/collectd: bump to version 5.10.0
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 18 Jan 2020 16:49:38 +0000 (17:49 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 19 Jan 2020 09:01:06 +0000 (10:01 +0100)
Remove first patch (already in version)

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/collectd/0001-configure.ac-fix-activation-of-snmp_agent.patch [deleted file]
package/collectd/0001-configure.ac-fix-protobuf-util-time_util.h-detection.patch [new file with mode: 0644]
package/collectd/0002-configure.ac-fix-protobuf-util-time_util.h-detection.patch [deleted file]
package/collectd/collectd.hash
package/collectd/collectd.mk

diff --git a/package/collectd/0001-configure.ac-fix-activation-of-snmp_agent.patch b/package/collectd/0001-configure.ac-fix-activation-of-snmp_agent.patch
deleted file mode 100644 (file)
index 783d572..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-From bfb85f1840f3672518979dd4b52f012fc08b4f88 Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Tue, 6 Aug 2019 09:36:13 +0200
-Subject: [PATCH] configure.ac: fix activation of snmp_agent
-
-If netsnmp library has been built without mib loading support (through
---disable-mib-loading), build of snmp_agent fails on:
-
-src/snmp_agent.c: In function 'snmp_agent_get_asn_type':
-src/snmp_agent.c:160:47: error: dereferencing pointer to incomplete type 'struct tree'
-   return (node != NULL) ? mib_to_asn_type(node->type) : 0;
-
-struct tree is defined in net-snmp/libray/parse.h which is included by
-net-snmp/mib_api.h only if NETSNMP_DISABLE_MIB_LOADING is not set.
-
-To fix this error, check for get_tree function in netsnmp library in
-addition to init_agent in netsnmpagent library
-
-Fixes:
- - http://autobuild.buildroot.org/results/6d7ac28f154f83208f949c62d28411855f1817f8
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-[Upstream status: https://github.com/collectd/collectd/pull/3241]
----
- configure.ac | 8 +++++++-
- 1 file changed, 7 insertions(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index add1556b..5ac33dc7 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -3950,7 +3950,13 @@ if test "x$with_libnetsnmpagent" = "xyes"; then
-   )
-   AC_CHECK_LIB([netsnmpagent], [init_agent],
--    [with_libnetsnmpagent="yes"],
-+    [
-+      # libnetsnmp can be built without without mib loading support
-+      AC_CHECK_LIB([netsnmp], [get_tree],
-+        [with_libnetsnmpagent="yes"],
-+        [with_libnetsnmpagent="no (libnetsnmp doesn't support mib loading)"]
-+      )
-+    ],
-     [with_libnetsnmpagent="no (libnetsnmpagent not found)"],
-     [$libnetsnmphelpers]
-   )
--- 
-2.20.1
-
diff --git a/package/collectd/0001-configure.ac-fix-protobuf-util-time_util.h-detection.patch b/package/collectd/0001-configure.ac-fix-protobuf-util-time_util.h-detection.patch
new file mode 100644 (file)
index 0000000..5eb22be
--- /dev/null
@@ -0,0 +1,50 @@
+From a81fb110f7685b3268cd921ba72a00796f43d034 Mon Sep 17 00:00:00 2001
+From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+Date: Tue, 29 Oct 2019 10:25:07 +0100
+Subject: [PATCH] configure.ac: fix protobuf/util/time_util.h detection
+
+Add -std=c++11 when checking gor protobuf/util/time_util.h otherwise
+test will fail on:
+
+configure:104495: checking google/protobuf/util/time_util.h usability
+configure:104495: /home/br-user/autobuild/run/instance-2/output/host/bin/mips-linux-gnu-g++ -c -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64  -Os  -D_FORTIFY_SOURCE=1  -pthread  conftest.cpp >&5
+In file included from /home/br-user/autobuild/run/instance-2/output/host/opt/ext-toolchain/mips-linux-gnu/include/c++/5.3.0/atomic:38:0,
+                 from /home/br-user/autobuild/run/instance-2/output/host/mips-buildroot-linux-gnu/sysroot/usr/include/google/protobuf/io/coded_stream.h:113,
+                 from /home/br-user/autobuild/run/instance-2/output/host/mips-buildroot-linux-gnu/sysroot/usr/include/google/protobuf/duration.pb.h:23,
+                 from /home/br-user/autobuild/run/instance-2/output/host/mips-buildroot-linux-gnu/sysroot/usr/include/google/protobuf/util/time_util.h:52,
+                 from conftest.cpp:188:
+/home/br-user/autobuild/run/instance-2/output/host/opt/ext-toolchain/mips-linux-gnu/include/c++/5.3.0/bits/c++0x_warning.h:32:2: error: #error This file requires compiler and library support for the ISO C++ 2011 standard. This support is currently experimental, and must be enabled with the -std=c++11 or -std=gnu++11 compiler options.
+
+Fixes:
+ - http://autobuild.buildroot.net/results/0d486edaf4c51b6438adeec61fe2c55099862acb
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+[Upstream status: https://github.com/collectd/collectd/pull/3325]
+---
+ configure.ac | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 34386d06..59a7f355 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -2722,6 +2722,7 @@ if test "x$withval" != "xno"; then
+   else
+     AC_MSG_RESULT([no])
+     with_libgrpcpp="no (requires C++11 support)"
++    with_libprotobuf="no (<google/protobuf/util/time_util.h> requires C++11 support)"
+   fi
+ fi
+@@ -4568,7 +4569,7 @@ if test "x$withval" != "xno"; then
+   AC_CHECK_LIB([protobuf], [main],
+     [
+       SAVE_CPPFLAGS="$CPPFLAGS"
+-      CPPFLAGS="$with_libprotobuf_cppflags $PROTOBUF_CFLAGS"
++      CPPFLAGS="-std=c++11 $with_libprotobuf_cppflags $PROTOBUF_CFLAGS"
+       if test "x$PROTOBUF_LIBS" = "x"
+       then
+         PROTOBUF_LIBS="-lprotobuf"
+-- 
+2.23.0
+
diff --git a/package/collectd/0002-configure.ac-fix-protobuf-util-time_util.h-detection.patch b/package/collectd/0002-configure.ac-fix-protobuf-util-time_util.h-detection.patch
deleted file mode 100644 (file)
index 5eb22be..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-From a81fb110f7685b3268cd921ba72a00796f43d034 Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Tue, 29 Oct 2019 10:25:07 +0100
-Subject: [PATCH] configure.ac: fix protobuf/util/time_util.h detection
-
-Add -std=c++11 when checking gor protobuf/util/time_util.h otherwise
-test will fail on:
-
-configure:104495: checking google/protobuf/util/time_util.h usability
-configure:104495: /home/br-user/autobuild/run/instance-2/output/host/bin/mips-linux-gnu-g++ -c -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64  -Os  -D_FORTIFY_SOURCE=1  -pthread  conftest.cpp >&5
-In file included from /home/br-user/autobuild/run/instance-2/output/host/opt/ext-toolchain/mips-linux-gnu/include/c++/5.3.0/atomic:38:0,
-                 from /home/br-user/autobuild/run/instance-2/output/host/mips-buildroot-linux-gnu/sysroot/usr/include/google/protobuf/io/coded_stream.h:113,
-                 from /home/br-user/autobuild/run/instance-2/output/host/mips-buildroot-linux-gnu/sysroot/usr/include/google/protobuf/duration.pb.h:23,
-                 from /home/br-user/autobuild/run/instance-2/output/host/mips-buildroot-linux-gnu/sysroot/usr/include/google/protobuf/util/time_util.h:52,
-                 from conftest.cpp:188:
-/home/br-user/autobuild/run/instance-2/output/host/opt/ext-toolchain/mips-linux-gnu/include/c++/5.3.0/bits/c++0x_warning.h:32:2: error: #error This file requires compiler and library support for the ISO C++ 2011 standard. This support is currently experimental, and must be enabled with the -std=c++11 or -std=gnu++11 compiler options.
-
-Fixes:
- - http://autobuild.buildroot.net/results/0d486edaf4c51b6438adeec61fe2c55099862acb
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-[Upstream status: https://github.com/collectd/collectd/pull/3325]
----
- configure.ac | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index 34386d06..59a7f355 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -2722,6 +2722,7 @@ if test "x$withval" != "xno"; then
-   else
-     AC_MSG_RESULT([no])
-     with_libgrpcpp="no (requires C++11 support)"
-+    with_libprotobuf="no (<google/protobuf/util/time_util.h> requires C++11 support)"
-   fi
- fi
-@@ -4568,7 +4569,7 @@ if test "x$withval" != "xno"; then
-   AC_CHECK_LIB([protobuf], [main],
-     [
-       SAVE_CPPFLAGS="$CPPFLAGS"
--      CPPFLAGS="$with_libprotobuf_cppflags $PROTOBUF_CFLAGS"
-+      CPPFLAGS="-std=c++11 $with_libprotobuf_cppflags $PROTOBUF_CFLAGS"
-       if test "x$PROTOBUF_LIBS" = "x"
-       then
-         PROTOBUF_LIBS="-lprotobuf"
--- 
-2.23.0
-
index 779e16d70a91010873c33dd61ed5f9e7053b56a4..7f716b7a93d6ef7bca5bdd1a96829b6b49c28231 100644 (file)
@@ -1,5 +1,5 @@
 # Locally computed checksums
-sha512 5386e4d0b9c350a0719924bf440f53bf3cdedefefe6bc7b154501dfdf7d2d98fa5dd31341cbed41023f7a129f68bda694e9d06f2da69ea2e61372d1b237b64a7        collectd-5.9.2.tar.bz2
-sha256 917c483608b9b38438b121737b510c3d68f335c091bc286aa6ebcc0c8e372a09        collectd-5.9.2.tar.bz2
-sha1   e8d0cb152194f3b51ee762a62ab647f7bb42e259        collectd-5.9.2.tar.bz2
+sha512 1296085fb19bba0c7b7d8684ec877851158b25c9f7b58fc3ae602fba7d7dc718876e730e1cdba96d39101cc5452705bb3445aaee717b219025ae816299b6a3c5        collectd-5.10.0.tar.bz2
+sha256 a03359f563023e744c2dc743008a00a848f4cd506e072621d86b6d8313c0375b        collectd-5.10.0.tar.bz2
+sha1   9d64ec4e6e834b8e417e282390e2a9c57934d3bc        collectd-5.10.0.tar.bz2
 sha256 ed0409b2b1c30566dab5fcdaf46ee70e140c99788e22f0267645a9357b476ae4        COPYING
index fd27443755379d5f9d59ace652e8897637c1ab4e..0cd86adbd4a7be9ac5ffc380dd0da3b635074046 100644 (file)
@@ -4,9 +4,9 @@
 #
 ################################################################################
 
-COLLECTD_VERSION = 5.9.2
+COLLECTD_VERSION = 5.10.0
 COLLECTD_SITE = \
-       https://github.com/collectd/collectd/releases/download/collectd-$(COLLECTD_VERSION)
+       https://github.com/collectd/collectd/releases/download/$(COLLECTD_VERSION)
 COLLECTD_SOURCE = collectd-$(COLLECTD_VERSION).tar.bz2
 COLLECTD_CONF_ENV = ac_cv_lib_yajl_yajl_alloc=yes
 COLLECTD_INSTALL_STAGING = YES