vlc: fix live555 support
authorSamuel Martin <s.martin49@gmail.com>
Sat, 8 Feb 2014 14:34:52 +0000 (15:34 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 8 Feb 2014 21:04:16 +0000 (22:04 +0100)
vlc looks for a *.pc file which is not provided by the live555 package.
So, instead, we explicitly set the LIVE555_CFLAGS and LIVE555_LIBS
variables.

Fixes:
  http://autobuild.buildroot.org/results/b59/b5972ecad4e5004dc23a2366066ce45346994f58/build-end.log

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/vlc/vlc.mk

index 10271516ac26a4552dcac090b38759cc60af31bd..feee82db98da7dae54795884c1e54b9cf07c390b 100644 (file)
@@ -194,6 +194,15 @@ endif
 ifeq ($(BR2_PACKAGE_LIVE555),y)
 VLC_CONF_OPT += --enable-live555
 VLC_DEPENDENCIES += live555
+VLC_CONF_ENV = \
+       LIVE555_CFLAGS="\
+               -I$(STAGING_DIR)/usr/include/live \
+               -I$(STAGING_DIR)/usr/include/live/BasicUsageEnvironment \
+               -I$(STAGING_DIR)/usr/include/live/groupsock \
+               -I$(STAGING_DIR)/usr/include/live/liveMedia \
+               -I$(STAGING_DIR)/usr/include/live/UsageEnvironment \
+               " \
+       LIVE555_LIBS="-L$(STAGING_DIR)/usr/lib -lliveMedia"
 else
 VLC_CONF_OPT += --disable-live555
 endif