netatalk: bump to version 3.1.7
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 3 Dec 2014 20:53:48 +0000 (17:53 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 3 Dec 2014 22:01:11 +0000 (23:01 +0100)
Rename patch to new standard and add hash file as well.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/netatalk/0001-Fix-setting-of-LD_LIBRARY_FLAGS-shlibpath_var.patch [new file with mode: 0644]
package/netatalk/0002-no-acl.patch [new file with mode: 0644]
package/netatalk/netatalk-0001-Fix-setting-of-LD_LIBRARY_FLAGS-shlibpath_var.patch [deleted file]
package/netatalk/netatalk.hash [new file with mode: 0644]
package/netatalk/netatalk.mk

diff --git a/package/netatalk/0001-Fix-setting-of-LD_LIBRARY_FLAGS-shlibpath_var.patch b/package/netatalk/0001-Fix-setting-of-LD_LIBRARY_FLAGS-shlibpath_var.patch
new file mode 100644 (file)
index 0000000..01d5776
--- /dev/null
@@ -0,0 +1,48 @@
+From 60d100713b5289948e9cdf5b0646ff3cdd2c206b Mon Sep 17 00:00:00 2001
+From: "Arnout Vandecappelle (Essensium/Mind)" <arnout@mind.be>
+Date: Mon, 17 Dec 2012 22:32:44 +0100
+Subject: [PATCH] Fix setting of LD_LIBRARY_FLAGS ($shlibpath_var).
+
+LD_LIBRARY_PATH should not be set when cross-compiling, because it
+adds the cross-libraries to the build's LD-path.
+
+Also the restoring of LD_LIBRARY_PATH was done incorrectly: it would
+set LD_LIBRARY_PATH=LD_LIBRARY_PATH.
+
+Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
+---
+ macros/db3-check.m4 |    6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/macros/db3-check.m4 b/macros/db3-check.m4
+index 902220b..d5a5446 100644
+--- a/macros/db3-check.m4
++++ b/macros/db3-check.m4
+@@ -94,7 +94,7 @@ if test "x$bdb_required" = "xyes"; then
+     savedldflags="$LDFLAGS"
+     savedcppflags="$CPPFLAGS"
+     savedlibs="$LIBS"
+-    saved_shlibpath_var=$shlibpath_var
++    eval saved_shlibpath_var=\$$shlibpath_var
+     dnl required BDB version: 4.6, because of cursor API change
+     DB_MAJOR_REQ=4
+@@ -148,7 +148,7 @@ if test "x$bdb_required" = "xyes"; then
+                         dnl -- LD_LIBRARY_PATH on many platforms. This will be fairly
+                         dnl -- portable hopefully. Reference:
+                         dnl -- http://lists.gnu.org/archive/html/autoconf/2009-03/msg00040.html
+-                        eval export $shlibpath_var=$bdblibdir
++                        test "$cross_compiling" = yes || eval export $shlibpath_var=$bdblibdir
+                         NETATALK_BDB_TRY_LINK
+                         eval export $shlibpath_var=$saved_shlibpath_var
+@@ -171,7 +171,7 @@ if test "x$bdb_required" = "xyes"; then
+                            CPPFLAGS="-I${bdbdir}/include${subdir} $CPPFLAGS"
+                            LDFLAGS="-L$bdblibdir $LDFLAGS"
+-                           eval export $shlibpath_var=$bdblibdir
++                           test "$cross_compiling" = yes || eval export $shlibpath_var=$bdblibdir
+                            NETATALK_BDB_TRY_LINK
+                            eval export $shlibpath_var=$saved_shlibpath_var
+-- 
diff --git a/package/netatalk/0002-no-acl.patch b/package/netatalk/0002-no-acl.patch
new file mode 100644 (file)
index 0000000..165141b
--- /dev/null
@@ -0,0 +1,15 @@
+Fix builds without acl, from http://sourceforge.net/p/netatalk/bugs/574/
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura netatalk-3.1.7.orig/include/atalk/acl.h netatalk-3.1.7/include/atalk/acl.h
+--- netatalk-3.1.7.orig/include/atalk/acl.h    2014-12-03 17:34:49.895524464 -0300
++++ netatalk-3.1.7/include/atalk/acl.h 2014-12-03 17:34:58.735243283 -0300
+@@ -61,6 +61,7 @@
+ #else /* HAVE_ACLS=no */
+ #define O_NETATALK_ACL 0
++#define O_IGNORE 0
+ #define chmod_acl chmod
+ #endif /* HAVE_ACLS */
diff --git a/package/netatalk/netatalk-0001-Fix-setting-of-LD_LIBRARY_FLAGS-shlibpath_var.patch b/package/netatalk/netatalk-0001-Fix-setting-of-LD_LIBRARY_FLAGS-shlibpath_var.patch
deleted file mode 100644 (file)
index 01d5776..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-From 60d100713b5289948e9cdf5b0646ff3cdd2c206b Mon Sep 17 00:00:00 2001
-From: "Arnout Vandecappelle (Essensium/Mind)" <arnout@mind.be>
-Date: Mon, 17 Dec 2012 22:32:44 +0100
-Subject: [PATCH] Fix setting of LD_LIBRARY_FLAGS ($shlibpath_var).
-
-LD_LIBRARY_PATH should not be set when cross-compiling, because it
-adds the cross-libraries to the build's LD-path.
-
-Also the restoring of LD_LIBRARY_PATH was done incorrectly: it would
-set LD_LIBRARY_PATH=LD_LIBRARY_PATH.
-
-Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
----
- macros/db3-check.m4 |    6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/macros/db3-check.m4 b/macros/db3-check.m4
-index 902220b..d5a5446 100644
---- a/macros/db3-check.m4
-+++ b/macros/db3-check.m4
-@@ -94,7 +94,7 @@ if test "x$bdb_required" = "xyes"; then
-     savedldflags="$LDFLAGS"
-     savedcppflags="$CPPFLAGS"
-     savedlibs="$LIBS"
--    saved_shlibpath_var=$shlibpath_var
-+    eval saved_shlibpath_var=\$$shlibpath_var
-     dnl required BDB version: 4.6, because of cursor API change
-     DB_MAJOR_REQ=4
-@@ -148,7 +148,7 @@ if test "x$bdb_required" = "xyes"; then
-                         dnl -- LD_LIBRARY_PATH on many platforms. This will be fairly
-                         dnl -- portable hopefully. Reference:
-                         dnl -- http://lists.gnu.org/archive/html/autoconf/2009-03/msg00040.html
--                        eval export $shlibpath_var=$bdblibdir
-+                        test "$cross_compiling" = yes || eval export $shlibpath_var=$bdblibdir
-                         NETATALK_BDB_TRY_LINK
-                         eval export $shlibpath_var=$saved_shlibpath_var
-@@ -171,7 +171,7 @@ if test "x$bdb_required" = "xyes"; then
-                            CPPFLAGS="-I${bdbdir}/include${subdir} $CPPFLAGS"
-                            LDFLAGS="-L$bdblibdir $LDFLAGS"
--                           eval export $shlibpath_var=$bdblibdir
-+                           test "$cross_compiling" = yes || eval export $shlibpath_var=$bdblibdir
-                            NETATALK_BDB_TRY_LINK
-                            eval export $shlibpath_var=$saved_shlibpath_var
--- 
diff --git a/package/netatalk/netatalk.hash b/package/netatalk/netatalk.hash
new file mode 100644 (file)
index 0000000..e201ae6
--- /dev/null
@@ -0,0 +1,3 @@
+# From http://sourceforge.net/projects/netatalk/files/netatalk/3.1.7/
+md5    831ec8bf9e084b64f965d16c528af299        netatalk-3.1.7.tar.bz2
+sha1   d4077a9496beae766ab1e4f28afa22e5c96514f0        netatalk-3.1.7.tar.bz2
index 6c1b64094dc861d5e40a6bd01f498748da18b9cc..725c33f7070296d5f97a616dffeaff62bdb9cb7d 100644 (file)
@@ -4,9 +4,10 @@
 #
 ################################################################################
 
-NETATALK_VERSION = 3.1.2
+NETATALK_VERSION = 3.1.7
 NETATALK_SITE = http://downloads.sourceforge.net/project/netatalk/netatalk/$(NETATALK_VERSION)
 NETATALK_SOURCE = netatalk-$(NETATALK_VERSION).tar.bz2
+# For 0001-Fix-setting-of-LD_LIBRARY_FLAGS-shlibpath_var.patch
 NETATALK_AUTORECONF = YES
 NETATALK_CONFIG_SCRIPTS = netatalk-config
 NETATALK_DEPENDENCIES = host-pkgconf openssl berkeleydb libgcrypt libgpg-error \