toolchain/ct-ng: use soft-float option from BR config
authorYann E. MORIN <yann.morin.1998@anciens.enib.fr>
Wed, 9 Feb 2011 22:57:22 +0000 (23:57 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 10 Feb 2011 10:23:59 +0000 (11:23 +0100)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/toolchain-crosstool-ng/crosstool-ng.mk

index 553d93b062c41c1110e87eb8726d3a0ea7d47041..d066e9832640ed9ee5643563829ecaa477d1614f 100644 (file)
@@ -191,7 +191,7 @@ endif
 #
 # Lots of other awfull sed manipulations go here, to override CT-NG's .config
 # with BR2 config options.
-# Known missing: arch options, floating point (HW/SW), uClibc/eglibc config...
+# Known missing: arch options, uClibc/eglibc config...
 #
 CTNG_FIX_DOT_CONFIG_SED += s:^(CT_INSTALL_DIR_RO)=y:\# \1 is not set:;
 CTNG_FIX_DOT_CONFIG_SED += s:^(|\# )(CT_ARCH_[BL]E).*:\# \2 is not set:;
@@ -223,6 +223,15 @@ ifneq ($(call qstrip,$(BR2_GCC_TARGET_TUNE)),)
 CTNG_FIX_DOT_CONFIG_SED += s:^(CT_ARCH_TUNE)=.*:\1=$(BR2_GCC_TARGET_TUNE):;
 endif
 
+# And floating point now
+ifeq ($(call qstrip,$(BR2_SOFT_FLOAT)),)
+CTNG_FIX_DOT_CONFIG_SED += s:^\# (CT_ARCH_FLOAT_HW) is not set:\1=y:;
+CTNG_FIX_DOT_CONFIG_SED += s:^(CT_ARCH_FLOAT_SW)=y:\# \1 is not set:;
+else
+CTNG_FIX_DOT_CONFIG_SED += s:^(CT_ARCH_FLOAT_HW)=y:\# \1 is not set:;
+CTNG_FIX_DOT_CONFIG_SED += s:^\# (CT_ARCH_FLOAT_SW) is not set:\1=y:;
+endif
+
 # Thread implementation selection
 CTNG_FIX_DOT_CONFIG_SED += s:^(|\# )(CT_THREADS_NONE).*:\# \2 is not set:;
 CTNG_FIX_DOT_CONFIG_SED += s:^(|\# )(CT_THREADS_LINUXTHREADS).*:\# \2 is not set:;