package/pkg-python: invalidate precompiled _sysconfigdata*.pyc
authorHerve Codina <herve.codina@bootlin.com>
Tue, 6 Jul 2021 14:24:50 +0000 (16:24 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Tue, 6 Jul 2021 20:53:42 +0000 (22:53 +0200)
For per-package directories, we fixup the _sysconfigdata*.py files, so
that they get proper path pointing to the current package's direcotry
structure.

However, the corresponding, pre-compiled blobs _sysconfigdata*.pyc were
left around, and thus are inconsistent with their source. They might
also be regenerated when a package would install a python module; this
regeneration would trigger the soon-to-be-introduced overwrite
detection.

This commit simply removes _sysconfigdata*.pyc files; they will anyway
be regenerated by the PYTHON{,3}_CREATE_PYC_FILES target finalize hooks.
This is an efficient way to guarantee the consistency between the source
and precompiled versions, and to not trigger the overwrite detection.

Signed-off-by: Herve Codina <herve.codina@bootlin.com>
[yann.morin.1998@free.frs: reword the commit log]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/pkg-python.mk

index 59a48e5a873d2bea1d642545cf55ec1661014811..1e4fd5ba33c87a03be8027da7d543543691f3e15 100644 (file)
@@ -97,6 +97,8 @@ define PKG_PYTHON_FIXUP_SYSCONFIGDATA
        find $(HOST_DIR)/lib/python* $(STAGING_DIR)/usr/lib/python* \
                -name "_sysconfigdata*.py" | xargs --no-run-if-empty \
                $(SED) "s:$(PER_PACKAGE_DIR)/[^/]\+/:$(PER_PACKAGE_DIR)/$($(PKG)_NAME)/:g"
+       find $(HOST_DIR)/lib/python* $(STAGING_DIR)/usr/lib/python* \
+               -name "_sysconfigdata*.pyc" -delete
 endef
 endif