package/netsniff-ng: Fix build caused by extra 'install' target
authorVadim Kochan <vadim4j@gmail.com>
Tue, 2 Apr 2019 14:23:58 +0000 (17:23 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 2 Apr 2019 18:18:19 +0000 (20:18 +0200)
After commit:

b0f98d5 package/netsniff-ng: allow to build with uclibc but w/o mausezahn

the different build and install targets are specified depending if
masuezahn tool is able to be selected or not. It works for the build
case but for the install the old 'install' target was not removed from
the make invocation and it still forces to install the mausezahn, so fix
it by remove this target.

Fixes:
http://autobuild.buildroot.net/results/cc44ed737799c9ac73628c82b86bd526b1c43310/
http://autobuild.buildroot.net/results/72d0753532720604d51c05663af7fbfe37434339/

Signed-off-by: Vadim Kochan <vadim4j@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/netsniff-ng/netsniff-ng.mk

index 8dd06b6fb720ec4eb623d8fd81f247522b42b940..415e86def15107418fa72471dca87e3c7e8e65bf 100644 (file)
@@ -54,7 +54,7 @@ endef
 
 define NETSNIFF_NG_INSTALL_TARGET_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) \
-               PREFIX=$(TARGET_DIR)/usr ETCDIR=$(TARGET_DIR)/etc install \
+               PREFIX=$(TARGET_DIR)/usr ETCDIR=$(TARGET_DIR)/etc \
                        -C $(@D) $(NETSNIFF_NG_INSTALL_MAKE_TARGET)
 endef