linux-firmware: add support for intel iwlwifi 9xxx
authorPeter Seiderer <ps.report@gmx.net>
Wed, 10 Jan 2018 21:38:59 +0000 (22:38 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 12 Jan 2018 19:01:00 +0000 (20:01 +0100)
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/linux-firmware/Config.in
package/linux-firmware/linux-firmware.mk

index 339bb99f1f7f5edb952174e96b8f8e8e1f3d9d89..e27fc35c4be752a12e64b006e73caa4b69d8cbbb 100644 (file)
@@ -156,6 +156,12 @@ config BR2_PACKAGE_LINUX_FIRMWARE_IWLWIFI_8265
          Firmware files for the Intel Wifi 8265 devices supported by
          the iwlwifi kernel driver.
 
+config BR2_PACKAGE_LINUX_FIRMWARE_IWLWIFI_9XXX
+       bool "Intel iwlwifi 9xxx"
+       help
+         Firmware files for the Intel Wifi 9xxx devices supported by
+         the iwlwifi kernel driver.
+
 config BR2_PACKAGE_LINUX_FIRMWARE_LIBERTAS_SD8686_V8
        bool "Libertas SD 8686 v8"
        help
index 1a4fbc15886cac939d8a18997e64374ba044ee14..394f2868c370ea9de6795d19b34fe7b2f0d1b4e0 100644 (file)
@@ -325,6 +325,11 @@ LINUX_FIRMWARE_FILES += iwlwifi-8265-*.ucode
 LINUX_FIRMWARE_ALL_LICENSE_FILES += LICENCE.iwlwifi_firmware
 endif
 
+ifeq ($(BR2_PACKAGE_LINUX_FIRMWARE_IWLWIFI_9XXX),y)
+LINUX_FIRMWARE_FILES += iwlwifi-9???-*.ucode
+LINUX_FIRMWARE_ALL_LICENSE_FILES += LICENCE.iwlwifi_firmware
+endif
+
 ifeq ($(BR2_PACKAGE_LINUX_FIRMWARE_BNX2X),y)
 LINUX_FIRMWARE_FILES += bnx2x/*
 # No license file; the license is in the file WHENCE