libiio: do not install systemd service file, no longer available
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 26 Aug 2016 20:49:02 +0000 (22:49 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 28 Aug 2016 13:52:13 +0000 (15:52 +0200)
Since the bump to libiio 0.7, the systemd service file that used to be
in debian/iiod.service no longer exists. The entire debian/ directory
has been removed from the upstream project:

  https://github.com/analogdevicesinc/libiio/commit/5d49f58982b0c15545bc70724304fbc580e6523c

Due to this, the installation of this service file fails, and causes
build failures. To address this, we simply remove the installation of
the systemd service file.

Fixes:

  http://autobuild.buildroot.net/results/ce2fc81466abd9619aa104c96234d1455de3480d/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libiio/libiio.mk

index 3cbfdd63f9755554ec99d45f150b2edef6274b6d..e8fb6b2f2526d32b7291bbb594e443437d0a6796 100644 (file)
@@ -79,13 +79,6 @@ define LIBIIO_INSTALL_INIT_SYSV
        $(INSTALL) -D -m 0755 package/libiio/S99iiod \
                $(TARGET_DIR)/etc/init.d/S99iiod
 endef
-define LIBIIO_INSTALL_INIT_SYSTEMD
-       $(INSTALL) -d $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
-       $(INSTALL) -D -m 0644 $(@D)/debian/iiod.service \
-               $(TARGET_DIR)/usr/lib/systemd/system/iiod.service
-       ln -fs ../../../../usr/lib/systemd/system/iiod.service \
-               $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/iiod.service
-endef
 endif
 
 $(eval $(cmake-package))