mysql: add mysql user
authorMarcelo Gutiérrez(UTN/FRH) <kuyurix@gmail.com>
Tue, 4 Mar 2014 14:50:01 +0000 (14:50 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 21 Jul 2014 21:52:27 +0000 (23:52 +0200)
[Thomas: do not define a password nor a shell, add a description for
the user.]

Signed-off-by: Marcelo Gutiérrez <kuyurix@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
merge user def

package/mysql/mysql.mk

index 21435f5a7c66b423d5b26762aeb2252d0ae65ce5..44dcb7e14ff1aec0f8f999dc1bd0bacbe55447f7 100644 (file)
@@ -89,6 +89,10 @@ define HOST_MYSQL_INSTALL_CMDS
        $(INSTALL) -m 0755  $(@D)/sql/gen_lex_hash  $(HOST_DIR)/usr/bin/
 endef
 
+define MYSQL_USERS
+       mysql -1 nogroup -1 * /var/mysql - - MySQL daemon
+endef
+
 define MYSQL_ADD_FOLDER
        $(INSTALL) -d $(TARGET_DIR)/var/mysql
 endef