use default binutils for microblaze
authorWaldemar Brodkorb <wbx@openadk.org>
Sun, 13 Apr 2014 09:46:58 +0000 (11:46 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 28 Apr 2014 20:08:23 +0000 (22:08 +0200)
Upstream binutils 2.24 works fine for microblaze, no need for
Xilinx Git.

[Peter: disable older versions as suggested by Gustavo]
Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Tested-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/binutils/Config.in.host
package/binutils/binutils.mk

index 2f86f517bf4e07fc900b0a18f024a5a7705ba964..5515570a81e134eba1082c4114bdece643d8a45a 100644 (file)
@@ -3,8 +3,8 @@ comment "Binutils Options"
 choice
        prompt "Binutils Version"
        depends on !BR2_arc
-       depends on !BR2_microblaze
        default BR2_BINUTILS_VERSION_2_21 if (BR2_mips || BR2_mipsel || BR2_sh)
+       default BR2_BINUTILS_VERSION_2_24 if BR2_microblaze
        default BR2_BINUTILS_VERSION_2_22
        help
          Select the version of binutils you wish to use.
@@ -14,30 +14,30 @@ choice
                bool "binutils 2.18-avr32-1.0.1"
 
        config BR2_BINUTILS_VERSION_2_20_1
-               depends on !BR2_avr32 && !BR2_aarch64
+               depends on !BR2_avr32 && !BR2_aarch64 && !BR2_microblaze
                depends on !BR2_ARM_EABIHF
                bool "binutils 2.20.1"
 
        config BR2_BINUTILS_VERSION_2_21
-               depends on !BR2_avr32 && !BR2_aarch64
+               depends on !BR2_avr32 && !BR2_aarch64 && !BR2_microblaze
                depends on !BR2_ARM_EABIHF
                bool "binutils 2.21"
 
        config BR2_BINUTILS_VERSION_2_21_1
-               depends on !BR2_avr32 && !BR2_aarch64
+               depends on !BR2_avr32 && !BR2_aarch64 && !BR2_microblaze
                depends on !BR2_ARM_EABIHF
                bool "binutils 2.21.1"
 
        config BR2_BINUTILS_VERSION_2_22
-               depends on !BR2_avr32 && !BR2_aarch64
+               depends on !BR2_avr32 && !BR2_aarch64 && !BR2_microblaze
                bool "binutils 2.22"
 
        config BR2_BINUTILS_VERSION_2_23_1
-               depends on !BR2_avr32 && !BR2_aarch64
+               depends on !BR2_avr32 && !BR2_aarch64 && !BR2_microblaze
                bool "binutils 2.23.1"
 
        config BR2_BINUTILS_VERSION_2_23_2
-               depends on !BR2_avr32 && !BR2_aarch64
+               depends on !BR2_avr32 && !BR2_aarch64 && !BR2_microblaze
                bool "binutils 2.23.2"
 
        config BR2_BINUTILS_VERSION_2_24
@@ -50,7 +50,6 @@ config BR2_BINUTILS_VERSION
        string
        default "2.18-avr32-1.0.1" if BR2_BINUTILS_VERSION_2_18_AVR32_1_0_1
        default "a934fe50786aa0dc0fb5da4754e7e07591c9cd8e" if BR2_arc
-       default "8351467c933d277ebea0c8d99ad2b65b5f7b6bc2" if BR2_microblaze
        default "2.20.1"        if BR2_BINUTILS_VERSION_2_20_1
        default "2.21"          if BR2_BINUTILS_VERSION_2_21
        default "2.21.1"        if BR2_BINUTILS_VERSION_2_21_1
index b5a2dc7fc582335acf02debc1aa0ff76ddb95a29..9cc4d288402ca867ea1fee74a7bbe455b0eae97f 100644 (file)
@@ -28,11 +28,6 @@ BINUTILS_SITE = $(call github,foss-for-synopsys-dwc-arc-processors,binutils,$(BI
 BINUTILS_SOURCE = binutils-$(BINUTILS_VERSION).tar.gz
 BINUTILS_FROM_GIT = y
 endif
-ifeq ($(BR2_microblaze),y)
-BINUTILS_SITE = $(call github,Xilinx,binutils,$(BINUTILS_VERSION))
-BINUTILS_SOURCE = binutils-$(BINUTILS_VERSION).tar.gz
-BINUTILS_FROM_GIT = y
-endif
 BINUTILS_SITE ?= $(BR2_GNU_MIRROR)/binutils
 BINUTILS_SOURCE ?= binutils-$(BINUTILS_VERSION).tar.bz2
 BINUTILS_EXTRA_CONFIG_OPTIONS = $(call qstrip,$(BR2_BINUTILS_EXTRA_CONFIG_OPTIONS))