mmc-utils: new package
authorSébastien Szymanski <sebastien.szymanski@armadeus.com>
Wed, 15 Jan 2014 12:55:54 +0000 (13:55 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 15 Jan 2014 14:00:46 +0000 (15:00 +0100)
mmc-utils provides tools to manipulate mmc device registers.

[Peter: drop uninstall, move to filesystem and flash utilities]
Signed-off-by: Sébastien Szymanski <sebastien.szymanski@armadeus.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/mmc-utils/Config.in [new file with mode: 0644]
package/mmc-utils/mmc-utils.mk [new file with mode: 0644]

index 78c0e066f5e2fa0d63a89c425a12b260ea043472..4611256d08482f5647d243f745490635c4813867 100644 (file)
@@ -144,6 +144,7 @@ source "package/genext2fs/Config.in"
 source "package/genromfs/Config.in"
 source "package/kobs-ng/Config.in"
 source "package/makedevs/Config.in"
+source "package/mmc-utils/Config.in"
 source "package/mtd/Config.in"
 source "package/nfs-utils/Config.in"
 source "package/ntfs-3g/Config.in"
diff --git a/package/mmc-utils/Config.in b/package/mmc-utils/Config.in
new file mode 100644 (file)
index 0000000..07650c8
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_MMC_UTILS
+       bool "mmc-utils"
+       depends on BR2_LARGEFILE
+       help
+         MMC utils
+
+         https://git.kernel.org/cgit/linux/kernel/git/cjb/mmc-utils.git
+
+comment "mmc-utils needs a toolchain w/ largefile"
+       depends on !BR2_LARGEFILE
diff --git a/package/mmc-utils/mmc-utils.mk b/package/mmc-utils/mmc-utils.mk
new file mode 100644 (file)
index 0000000..372d840
--- /dev/null
@@ -0,0 +1,19 @@
+################################################################################
+#
+# mmc-utils
+#
+################################################################################
+
+MMC_UTILS_VERSION = 11f2ceabc4ad3f0dd568e0ce68166e4803e0615b
+MMC_UTILS_SITE    = git://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git
+MMC_UTILS_LICENSE = GPLv2
+
+define MMC_UTILS_BUILD_CMDS
+       $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS)
+endef
+
+define MMC_UTILS_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/mmc $(TARGET_DIR)/usr/bin/mmc
+endef
+
+$(eval $(generic-package))