gst-plugins-base: bump version
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 14 Mar 2012 17:25:47 +0000 (18:25 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 14 Mar 2012 22:05:45 +0000 (23:05 +0100)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/gst-plugins-base/gst-plugins-base-0.10.35-disable-testchannels-example.patch [deleted file]
package/multimedia/gst-plugins-base/gst-plugins-base-0.10.35-tremor.patch [deleted file]
package/multimedia/gst-plugins-base/gst-plugins-base-tremor.patch [new file with mode: 0644]
package/multimedia/gst-plugins-base/gst-plugins-base.mk

diff --git a/package/multimedia/gst-plugins-base/gst-plugins-base-0.10.35-disable-testchannels-example.patch b/package/multimedia/gst-plugins-base/gst-plugins-base-0.10.35-disable-testchannels-example.patch
deleted file mode 100644 (file)
index e991c4e..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-[PATCH] disable testchannels example
-
-The testchannels example doesn't build because it forgets to link with
-libgstinterfaces. Unfortunately testchannels gets built even though
---disable-examples is used, so instead disable it in Makefile.in
-(package doesn't autoreconf cleanly, so don't edit Makefile.am)
-
-Problem is fixed upstream in 0.11 branch (940291dd38be66fa).
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- gst-libs/gst/audio/Makefile.in |    1 -
- 1 file changed, 1 deletion(-)
-
-Index: gst-plugins-base-0.10.35/gst-libs/gst/audio/Makefile.in
-===================================================================
---- gst-plugins-base-0.10.35.orig/gst-libs/gst/audio/Makefile.in
-+++ gst-plugins-base-0.10.35/gst-libs/gst/audio/Makefile.in
-@@ -45,7 +45,6 @@
- POST_UNINSTALL = :
- build_triplet = @build@
- host_triplet = @host@
--noinst_PROGRAMS = testchannels$(EXEEXT)
- DIST_COMMON = $(libgstaudio_@GST_MAJORMINOR@include_HEADERS) \
-       $(srcdir)/Makefile.am $(srcdir)/Makefile.in \
-       $(top_srcdir)/common/gst-glib-gen.mak TODO
diff --git a/package/multimedia/gst-plugins-base/gst-plugins-base-0.10.35-tremor.patch b/package/multimedia/gst-plugins-base/gst-plugins-base-0.10.35-tremor.patch
deleted file mode 100644 (file)
index fa8785b..0000000
+++ /dev/null
@@ -1,139 +0,0 @@
-From 0088753651350de3060ece22c1be4153b6009515 Mon Sep 17 00:00:00 2001
-From: Peter Korsgaard <jacmet@sunsite.dk>
-Date: Wed, 25 Jan 2012 23:53:04 +0100
-Subject: [PATCH] base: vorbisdeclib: support modern Tremor versions
-
-Reported upstream as https://bugzilla.gnome.org/show_bug.cgi?id=668726
-
-Tremor changed to use standard libogg rather than its own incompatible
-copy back in Aug 2010 (r17375), causing gst-plugin-base build to fail.
-
-Tremolo so far unfortunately hasn't been updated. Restructure
-vorbisdeclib.h so the legacy _ogg_packet_wrapper code is only used for
-Tremolo.
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- ext/vorbis/gstvorbisdeclib.h |   77 ++++++++++++++++++++++-------------------
- 1 files changed, 41 insertions(+), 36 deletions(-)
-
-diff --git a/ext/vorbis/gstvorbisdeclib.h b/ext/vorbis/gstvorbisdeclib.h
-index ca00af9..e147591 100644
---- a/ext/vorbis/gstvorbisdeclib.h
-+++ b/ext/vorbis/gstvorbisdeclib.h
-@@ -29,11 +29,6 @@
- #ifndef TREMOR
--#include <vorbis/codec.h>
--
--typedef float                          vorbis_sample_t;
--typedef ogg_packet                     ogg_packet_wrapper;
--
- #define GST_VORBIS_DEC_DESCRIPTION "decode raw vorbis streams to float audio"
- #define GST_VORBIS_DEC_SRC_CAPS \
-@@ -47,6 +42,42 @@ typedef ogg_packet                     ogg_packet_wrapper;
- #define GST_VORBIS_DEC_GLIB_TYPE_NAME      GstVorbisDec
-+#else /* TREMOR */
-+
-+#define GST_VORBIS_DEC_DESCRIPTION "decode raw vorbis streams to integer audio"
-+
-+#define GST_VORBIS_DEC_SRC_CAPS \
-+    GST_STATIC_CAPS ("audio/x-raw-int, "   \
-+        "rate = (int) [ 1, MAX ], "        \
-+        "channels = (int) [ 1, 6 ], "      \
-+        "endianness = (int) BYTE_ORDER, "  \
-+        "width = (int) { 16, 32 }, "       \
-+        "depth = (int) 16, "               \
-+        "signed = (boolean) true")
-+
-+#define GST_VORBIS_DEC_DEFAULT_SAMPLE_WIDTH           (16)
-+
-+/* we need a different type name here */
-+#define GST_VORBIS_DEC_GLIB_TYPE_NAME      GstIVorbisDec
-+
-+/* and still have it compile */
-+typedef struct _GstVorbisDec               GstIVorbisDec;
-+typedef struct _GstVorbisDecClass          GstIVorbisDecClass;
-+
-+#endif /* TREMOR */
-+
-+#ifndef USE_TREMOLO
-+
-+#ifdef TREMOR
-+ #include <tremor/ivorbiscodec.h>
-+ typedef ogg_int32_t                    vorbis_sample_t;
-+#else
-+ #include <vorbis/codec.h>
-+ typedef float                          vorbis_sample_t;
-+#endif
-+
-+typedef ogg_packet                     ogg_packet_wrapper;
-+
- static inline guint8 *
- gst_ogg_packet_data (ogg_packet * p)
- {
-@@ -72,17 +103,11 @@ gst_ogg_packet_from_wrapper (ogg_packet_wrapper * packet)
-   return packet;
- }
--#else
--
--#ifdef USE_TREMOLO
--  #include <Tremolo/ivorbiscodec.h>
--  #include <Tremolo/codec_internal.h>
--  typedef ogg_int16_t                    vorbis_sample_t;
--#else
--  #include <tremor/ivorbiscodec.h>
--  typedef ogg_int32_t                    vorbis_sample_t;
--#endif
-+#else /* USE_TREMOLO */
-+#include <Tremolo/ivorbiscodec.h>
-+#include <Tremolo/codec_internal.h>
-+typedef ogg_int16_t                    vorbis_sample_t;
- typedef struct _ogg_packet_wrapper     ogg_packet_wrapper;
- struct _ogg_packet_wrapper {
-@@ -91,26 +116,6 @@ struct _ogg_packet_wrapper {
-   ogg_buffer          buf;
- };
--#define GST_VORBIS_DEC_DESCRIPTION "decode raw vorbis streams to integer audio"
--
--#define GST_VORBIS_DEC_SRC_CAPS \
--    GST_STATIC_CAPS ("audio/x-raw-int, "   \
--        "rate = (int) [ 1, MAX ], "        \
--        "channels = (int) [ 1, 6 ], "      \
--        "endianness = (int) BYTE_ORDER, "  \
--        "width = (int) { 16, 32 }, "       \
--        "depth = (int) 16, "               \
--        "signed = (boolean) true")
--
--#define GST_VORBIS_DEC_DEFAULT_SAMPLE_WIDTH           (16)
--
--/* we need a different type name here */
--#define GST_VORBIS_DEC_GLIB_TYPE_NAME      GstIVorbisDec
--
--/* and still have it compile */
--typedef struct _GstVorbisDec               GstIVorbisDec;
--typedef struct _GstVorbisDecClass          GstIVorbisDecClass;
--
- /* compensate minor variation */
- #define vorbis_synthesis(a, b)             vorbis_synthesis (a, b, 1)
-@@ -154,7 +159,7 @@ gst_ogg_packet_from_wrapper (ogg_packet_wrapper * packet)
-   return &(packet->packet);
- }
--#endif
-+#endif /* USE_TREMOLO */
- typedef void (*CopySampleFunc)(vorbis_sample_t *out, vorbis_sample_t **in,
-                            guint samples, gint channels, gint width);
--- 
-1.7.8.3
-
diff --git a/package/multimedia/gst-plugins-base/gst-plugins-base-tremor.patch b/package/multimedia/gst-plugins-base/gst-plugins-base-tremor.patch
new file mode 100644 (file)
index 0000000..fa8785b
--- /dev/null
@@ -0,0 +1,139 @@
+From 0088753651350de3060ece22c1be4153b6009515 Mon Sep 17 00:00:00 2001
+From: Peter Korsgaard <jacmet@sunsite.dk>
+Date: Wed, 25 Jan 2012 23:53:04 +0100
+Subject: [PATCH] base: vorbisdeclib: support modern Tremor versions
+
+Reported upstream as https://bugzilla.gnome.org/show_bug.cgi?id=668726
+
+Tremor changed to use standard libogg rather than its own incompatible
+copy back in Aug 2010 (r17375), causing gst-plugin-base build to fail.
+
+Tremolo so far unfortunately hasn't been updated. Restructure
+vorbisdeclib.h so the legacy _ogg_packet_wrapper code is only used for
+Tremolo.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ ext/vorbis/gstvorbisdeclib.h |   77 ++++++++++++++++++++++-------------------
+ 1 files changed, 41 insertions(+), 36 deletions(-)
+
+diff --git a/ext/vorbis/gstvorbisdeclib.h b/ext/vorbis/gstvorbisdeclib.h
+index ca00af9..e147591 100644
+--- a/ext/vorbis/gstvorbisdeclib.h
++++ b/ext/vorbis/gstvorbisdeclib.h
+@@ -29,11 +29,6 @@
+ #ifndef TREMOR
+-#include <vorbis/codec.h>
+-
+-typedef float                          vorbis_sample_t;
+-typedef ogg_packet                     ogg_packet_wrapper;
+-
+ #define GST_VORBIS_DEC_DESCRIPTION "decode raw vorbis streams to float audio"
+ #define GST_VORBIS_DEC_SRC_CAPS \
+@@ -47,6 +42,42 @@ typedef ogg_packet                     ogg_packet_wrapper;
+ #define GST_VORBIS_DEC_GLIB_TYPE_NAME      GstVorbisDec
++#else /* TREMOR */
++
++#define GST_VORBIS_DEC_DESCRIPTION "decode raw vorbis streams to integer audio"
++
++#define GST_VORBIS_DEC_SRC_CAPS \
++    GST_STATIC_CAPS ("audio/x-raw-int, "   \
++        "rate = (int) [ 1, MAX ], "        \
++        "channels = (int) [ 1, 6 ], "      \
++        "endianness = (int) BYTE_ORDER, "  \
++        "width = (int) { 16, 32 }, "       \
++        "depth = (int) 16, "               \
++        "signed = (boolean) true")
++
++#define GST_VORBIS_DEC_DEFAULT_SAMPLE_WIDTH           (16)
++
++/* we need a different type name here */
++#define GST_VORBIS_DEC_GLIB_TYPE_NAME      GstIVorbisDec
++
++/* and still have it compile */
++typedef struct _GstVorbisDec               GstIVorbisDec;
++typedef struct _GstVorbisDecClass          GstIVorbisDecClass;
++
++#endif /* TREMOR */
++
++#ifndef USE_TREMOLO
++
++#ifdef TREMOR
++ #include <tremor/ivorbiscodec.h>
++ typedef ogg_int32_t                    vorbis_sample_t;
++#else
++ #include <vorbis/codec.h>
++ typedef float                          vorbis_sample_t;
++#endif
++
++typedef ogg_packet                     ogg_packet_wrapper;
++
+ static inline guint8 *
+ gst_ogg_packet_data (ogg_packet * p)
+ {
+@@ -72,17 +103,11 @@ gst_ogg_packet_from_wrapper (ogg_packet_wrapper * packet)
+   return packet;
+ }
+-#else
+-
+-#ifdef USE_TREMOLO
+-  #include <Tremolo/ivorbiscodec.h>
+-  #include <Tremolo/codec_internal.h>
+-  typedef ogg_int16_t                    vorbis_sample_t;
+-#else
+-  #include <tremor/ivorbiscodec.h>
+-  typedef ogg_int32_t                    vorbis_sample_t;
+-#endif
++#else /* USE_TREMOLO */
++#include <Tremolo/ivorbiscodec.h>
++#include <Tremolo/codec_internal.h>
++typedef ogg_int16_t                    vorbis_sample_t;
+ typedef struct _ogg_packet_wrapper     ogg_packet_wrapper;
+ struct _ogg_packet_wrapper {
+@@ -91,26 +116,6 @@ struct _ogg_packet_wrapper {
+   ogg_buffer          buf;
+ };
+-#define GST_VORBIS_DEC_DESCRIPTION "decode raw vorbis streams to integer audio"
+-
+-#define GST_VORBIS_DEC_SRC_CAPS \
+-    GST_STATIC_CAPS ("audio/x-raw-int, "   \
+-        "rate = (int) [ 1, MAX ], "        \
+-        "channels = (int) [ 1, 6 ], "      \
+-        "endianness = (int) BYTE_ORDER, "  \
+-        "width = (int) { 16, 32 }, "       \
+-        "depth = (int) 16, "               \
+-        "signed = (boolean) true")
+-
+-#define GST_VORBIS_DEC_DEFAULT_SAMPLE_WIDTH           (16)
+-
+-/* we need a different type name here */
+-#define GST_VORBIS_DEC_GLIB_TYPE_NAME      GstIVorbisDec
+-
+-/* and still have it compile */
+-typedef struct _GstVorbisDec               GstIVorbisDec;
+-typedef struct _GstVorbisDecClass          GstIVorbisDecClass;
+-
+ /* compensate minor variation */
+ #define vorbis_synthesis(a, b)             vorbis_synthesis (a, b, 1)
+@@ -154,7 +159,7 @@ gst_ogg_packet_from_wrapper (ogg_packet_wrapper * packet)
+   return &(packet->packet);
+ }
+-#endif
++#endif /* USE_TREMOLO */
+ typedef void (*CopySampleFunc)(vorbis_sample_t *out, vorbis_sample_t **in,
+                            guint samples, gint channels, gint width);
+-- 
+1.7.8.3
+
index 3b21c2701ed35fbdb94a2e386e9f9a54415026f9..848eaf290936e7a1851ca7551475438de7c32af5 100644 (file)
@@ -3,7 +3,7 @@
 # gst-plugins-base
 #
 #############################################################
-GST_PLUGINS_BASE_VERSION = 0.10.35
+GST_PLUGINS_BASE_VERSION = 0.10.36
 GST_PLUGINS_BASE_SOURCE = gst-plugins-base-$(GST_PLUGINS_BASE_VERSION).tar.bz2
 GST_PLUGINS_BASE_SITE = http://gstreamer.freedesktop.org/src/gst-plugins-base
 GST_PLUGINS_BASE_INSTALL_STAGING = YES
@@ -174,4 +174,10 @@ else
 GST_PLUGINS_BASE_CONF_OPT += --disable-vorbis
 endif
 
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+GST_PLUGINS_BASE_DEPENDENCIES += zlib
+else
+GST_PLUGINS_BASE_CONF_OPT += --disable-zlib
+endif
+
 $(eval $(call AUTOTARGETS))