package/easyframes: new package
authorHoratiu Vultur <horatiu.vultur@microchip.com>
Sat, 29 Aug 2020 07:24:16 +0000 (09:24 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 29 Aug 2020 10:04:01 +0000 (12:04 +0200)
Signed-off-by: Horatiu Vultur <horatiu.vultur@microchip.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/easyframes/Config.in [new file with mode: 0644]
package/easyframes/easyframes.hash [new file with mode: 0644]
package/easyframes/easyframes.mk [new file with mode: 0644]

index f4980c72cbaa6bf86fab95d2ac770700e4a75e11..5b783a7fe44e2aa3c1110faa5b105ac9c2a67008 100644 (file)
@@ -1110,6 +1110,9 @@ F:        package/gauche/
 F:     package/gmrender-resurrect/
 F:     package/squeezelite/
 
+N:     Horatiu Vultur <horatiu.vultur@microchip.com>
+F:     package/easyframes/
+
 N:     Ian Haylock <haylocki@yahoo.co.uk>
 F:     package/python-rpi-gpio/
 
index efa5e474c327006131aa875b0ca0565b83c66f5a..f5cdf7c55ab8768e1922e22a1f5a7d1a017d676c 100644 (file)
@@ -2046,6 +2046,7 @@ menu "Networking applications"
        source "package/dnsmasq/Config.in"
        source "package/drbd-utils/Config.in"
        source "package/dropbear/Config.in"
+       source "package/easyframes/Config.in"
        source "package/ebtables/Config.in"
        source "package/ejabberd/Config.in"
        source "package/ethtool/Config.in"
diff --git a/package/easyframes/Config.in b/package/easyframes/Config.in
new file mode 100644 (file)
index 0000000..b2c4549
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_EASYFRAMES
+       bool "easyframes"
+       select BR2_PACKAGE_LIBPCAP
+       help
+         This is a small and simple command-line tool for network
+         testing.  The tool makes it simple to compose a frame,
+         inject and express what and where frames are expected to be
+         received.
+
+         https://github.com/microchip-ung/easyframes
diff --git a/package/easyframes/easyframes.hash b/package/easyframes/easyframes.hash
new file mode 100644 (file)
index 0000000..0f16e0c
--- /dev/null
@@ -0,0 +1,3 @@
+# locally calculated
+sha256 3c0449b3129c29b5ecf67b689f1a75ffc65fde3c5f62811e2f0439ce4f4af392 easyframes-0.3.tar.gz
+sha256 24f37598e822a1411fb7164ce7eb3ef120aea8279016399abc282c2381ce3f57 COPYING
diff --git a/package/easyframes/easyframes.mk b/package/easyframes/easyframes.mk
new file mode 100644 (file)
index 0000000..2c20943
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# easyframes
+#
+################################################################################
+
+EASYFRAMES_VERSION = 0.3
+EASYFRAMES_SITE = $(call github,microchip-ung,easyframes,v$(EASYFRAMES_VERSION))
+EASYFRAMES_DEPENDENCIES = libpcap
+EASYFRAMES_LICENSE = MIT
+EASYFRAMES_LICENSE_FILES = COPYING
+
+$(eval $(cmake-package))