toolchain/helpers.mk: don't discard check_arm_abi stderr
authorBaruch Siach <baruch@tkos.co.il>
Thu, 3 Jul 2014 16:32:58 +0000 (19:32 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 4 Jul 2014 21:21:49 +0000 (23:21 +0200)
Since we only need to know whether the compiler runs successfully, and
stderr is empty for the success case, there is no need to redirect stderr to
/dev/null. Moreover, stderr output of the failing case reveals valuable
information on the real failure reason.

Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
toolchain/helpers.mk

index 81e02b71328467ff54d80c02bf2b71c26d18df72..c8c645a3118d6a310b3834f793043643e571ac54 100644 (file)
@@ -297,7 +297,7 @@ check_arm_abi = \
                echo "External toolchain uses the unsuported OABI" ; \
                exit 1 ; \
        fi ; \
-       if ! echo 'int main(void) {}' | $${__CROSS_CC} -x c -o /dev/null - 2>/dev/null; then \
+       if ! echo 'int main(void) {}' | $${__CROSS_CC} -x c -o /dev/null - ; then \
                abistr_$(BR2_ARM_EABI)='EABI'; \
                abistr_$(BR2_ARM_EABIHF)='EABIhf'; \
                echo "Incorrect ABI setting: $${abistr_y} selected, but toolchain is incompatible"; \