package/pkg-meson.mk: simplify sed-expression to add to [binaries]
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 6 Oct 2019 15:10:21 +0000 (17:10 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 8 Oct 2019 21:22:33 +0000 (23:22 +0200)
There is no need to memorise the matched pattern; it's a left-over
from a previous attempt.

However, ensure the pattern is correctly anchored to the beginning and
end of the line, to avoid accidentally matching it anywhere else (e,g,
in a comment).

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Eric Le Bihan <eric.le.bihan.dev@free.fr>
Cc: Peter Seiderer <ps.report@gmx.net>
Cc: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/pkg-meson.mk

index f5c7b8ced343338cab457fe60be2c9bb4b33c4ad..184a22a44a1c625ea60fde8cdc09ca043d9014af 100644 (file)
@@ -80,7 +80,7 @@ define $(2)_CONFIGURE_CMDS
            -e "s%@TARGET_CXXFLAGS@%$$($(2)_MESON_SED_CXXFLAGS)%g" \
            -e "s%@HOST_DIR@%$$(HOST_DIR)%g" \
            $$(foreach x,$$($(2)_MESON_EXTRA_BINARIES), \
-               -e "/\(\[binaries\]\)/s:$$$$:\n$$(x):" \
+               -e "/^\[binaries\]$$$$/s:$$$$:\n$$(x):" \
            ) \
            package/meson/cross-compilation.conf.in \
            > $$($$(PKG)_SRCDIR)/build/cross-compilation.conf