libiscsi: Force configure to use gcc for LD
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>
Tue, 28 Jul 2015 14:26:31 +0000 (16:26 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 28 Jul 2015 21:06:57 +0000 (23:06 +0200)
Fixes
http://autobuild.buildroot.org/results/0a9/0a96f3654983ed2efc851522352dec43c1df0077/

[Thomas:
  - pass the CC variable in <pkg>_CONF_ENV instead of <pkg>_CONF_OPTS
  - add comment in the code explaining why we are doing this.]

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libiscsi/libiscsi.mk

index 7877cd959b99aec80c8353949ec9dd97cde4bb50..adb94bdb29be0451c82489fdc84d688991385ff5 100644 (file)
@@ -10,4 +10,8 @@ LIBISCSI_LICENSE = GPLv2+ LGPLv2.1+
 LIBISCSI_LICENSE_FILES = COPYING LICENCE-GPL-2.txt LICENCE-LGPL-2.1.txt
 LIBISCSI_INSTALL_STAGING = YES
 
+# Force libiscsi to use gcc as the linker, otherwise it uses directly
+# ld, which doesn't work for certain architectures.
+LIBISCSI_CONF_ENV = LD="$(TARGET_CC)"
+
 $(eval $(autotools-package))