gnuchess: use the new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 20:47:09 +0000 (22:47 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:27:26 +0000 (01:27 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - dropping BR2_PACKAGE_GETTEXT selection

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gnuchess/Config.in
package/gnuchess/gnuchess.mk

index 4993b1adf035df1989a060671d7a78ee2ea2b4a9..aa446f4b22cc2beaccab2a048206345971ebe62e 100644 (file)
@@ -3,7 +3,6 @@ config BR2_PACKAGE_GNUCHESS
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_TOOLCHAIN_HAS_THREADS
        select BR2_PACKAGE_FLEX
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
        help
          GNU Chess lets most modern computers play a full game of chess.
 
index 010336738d87b358a87534beed5059a14c8e313c..1465ab0a0088cfbef223fde9247d570a8b53ecf2 100644 (file)
@@ -11,6 +11,6 @@ GNUCHESS_LICENSE_FILES = COPYING
 
 GNUCHESS_DEPENDENCIES = host-flex flex
 GNUCHESS_DEPENDENCIES += $(if $(BR2_PACKAGE_READLINE),readline) \
-       $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext)
+       $(TARGET_NLS_DEPENDENCIES)
 
 $(eval $(autotools-package))