sed: bump to 4.2.1 to fix build failure
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 9 May 2010 20:52:10 +0000 (22:52 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 10 May 2010 21:43:04 +0000 (23:43 +0200)
Version 4.1.5 fails to build due to the infamous getline() conflict
issue. 4.2.1 doesn't have this problem.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/sed/sed.mk

index 35cedce5b1182650f3e111ee0c139b33382a2cab..e5a5d005bb501665d9ee0172ed1ac58ecdd0f9f3 100644 (file)
@@ -3,7 +3,7 @@
 # sed
 #
 #############################################################
-SED_VERSION:=4.1.5
+SED_VERSION:=4.2.1
 SED_SOURCE:=sed-$(SED_VERSION).tar.gz
 SED_SITE:=$(BR2_GNU_MIRROR)/sed
 SED_CAT:=$(ZCAT)
@@ -100,7 +100,7 @@ endif
 #############################################################
 $(SED_DIR2)/.unpacked: $(DL_DIR)/$(SED_SOURCE)
        $(SED_CAT) $(DL_DIR)/$(SED_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       $(CONFIG_UPDATE) $(SED_DIR2)/config
+       $(CONFIG_UPDATE) $(SED_DIR2)/build-aux
        touch $@
 
 $(SED_DIR2)/.configured: $(SED_DIR2)/.unpacked