openocd: avoid documentation rebuild to fix build issues
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 26 Feb 2017 22:22:16 +0000 (23:22 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 28 Feb 2017 08:51:42 +0000 (09:51 +0100)
On PowerPC64(le), we patch all configure scripts. Due to this, the
version.texi in OpenOCD files gets regenerated, and then since it has
a newer date than openocd.info, openocd build system rebuilds the
documentation. Unfortunately, this documentation rebuild fails on old
machines.

We work around this by faking the date of the generated version.texi
file, to make the build system believe the documentation doesn't need
to be regenerated.

Fixes:

  http://autobuild.buildroot.net/results/3cbe65a46e75b8e67846d593884c96df97dec7a4

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: Sam Bobroff <sam.bobroff@au1.ibm.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/openocd/openocd.mk

index 21a302ff25cfa0916da853822abb04a9549583f7..0d1836573dcc0cbcda2530a145febef415c9dc8b 100644 (file)
@@ -99,5 +99,20 @@ HOST_OPENOCD_CONF_OPTS = \
 
 HOST_OPENOCD_DEPENDENCIES = host-libftdi host-libusb host-libusb-compat
 
+# Avoid documentation rebuild. On PowerPC64(le), we patch the
+# configure script. Due to this, the version.texi files gets
+# regenerated, and then since it has a newer date than openocd.info,
+# openocd build system rebuilds the documentation. Unfortunately, this
+# documentation rebuild fails on old machines. We work around this by
+# faking the date of the generated version.texi file, to make the
+# build system believe the documentation doesn't need to be
+# regenerated.
+define OPENOCD_FIX_VERSION_TEXI
+       touch -r $(@D)/doc/openocd.info $(@D)/doc/version.texi
+endef
+OPENOCD_POST_BUILD_HOOKS += OPENOCD_FIX_VERSION_TEXI
+HOST_OPENOCD_POST_BUILD_HOOKS += OPENOCD_FIX_VERSION_TEXI
+
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))