package/genimage: bump to version 12
authorPierre-Jean Texier <pjtexier@koncepto.io>
Fri, 31 Jan 2020 16:59:31 +0000 (17:59 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 1 Feb 2020 11:06:23 +0000 (12:06 +0100)
Also drop upstreamed patch

Signed-off-by: Pierre-Jean Texier <pjtexier@koncepto.io>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/genimage/0001-image-vfat-Add-label-option-to-set-volume-name.patch [deleted file]
package/genimage/genimage.hash
package/genimage/genimage.mk

diff --git a/package/genimage/0001-image-vfat-Add-label-option-to-set-volume-name.patch b/package/genimage/0001-image-vfat-Add-label-option-to-set-volume-name.patch
deleted file mode 100644 (file)
index a77b826..0000000
+++ /dev/null
@@ -1,69 +0,0 @@
-From c1a165731298b96175b9b0dd80ad088dc8b33dc1 Mon Sep 17 00:00:00 2001
-From: Florent Viard <fviard@cxignited.com>
-Date: Sun, 27 Oct 2019 23:48:16 +0100
-Subject: [PATCH] image-vfat: Add label option to set volume name.
-
-Signed-off-by: Florent Viard <fviard@cxignited.com>
-[dariobin@libero.it: remove README.rst changes]
-Signed-off-by: Dario Binacchi <dariobin@libero.it>
----
- image-vfat.c | 18 ++++++++++++++++--
- 1 file changed, 16 insertions(+), 2 deletions(-)
-
-diff --git a/image-vfat.c b/image-vfat.c
-index f16242c..3ea7288 100644
---- a/image-vfat.c
-+++ b/image-vfat.c
-@@ -27,14 +27,20 @@ static int vfat_generate(struct image *image)
-       int ret;
-       struct partition *part;
-       char *extraargs = cfg_getstr(image->imagesec, "extraargs");
-+      char *label = cfg_getstr(image->imagesec, "label");
-+
-+      if (label && label[0] != '\0')
-+              xasprintf(&label, "-n '%s'", label);
-+      else
-+              label = "";
-       ret = systemp(image, "%s if=/dev/zero of=\"%s\" seek=%lld count=0 bs=1 2>/dev/null",
-                       get_opt("dd"), imageoutfile(image), image->size);
-       if (ret)
-               return ret;
--      ret = systemp(image, "%s %s '%s'", get_opt("mkdosfs"),
--                      extraargs, imageoutfile(image));
-+      ret = systemp(image, "%s %s %s '%s'", get_opt("mkdosfs"),
-+                      extraargs, label, imageoutfile(image));
-       if (ret)
-               return ret;
-@@ -72,11 +78,18 @@ static int vfat_generate(struct image *image)
- static int vfat_setup(struct image *image, cfg_t *cfg)
- {
-+      char *label = cfg_getstr(image->imagesec, "label");
-+
-       if (!image->size) {
-               image_error(image, "no size given or must not be zero\n");
-               return -EINVAL;
-       }
-+      if (label && strlen(label) > 11) {
-+              image_error(image, "vfat volume name cannot be longer than 11 characters\n");
-+              return -EINVAL;
-+      }
-+
-       return 0;
- }
-@@ -112,6 +125,7 @@ static cfg_opt_t file_opts[] = {
- static cfg_opt_t vfat_opts[] = {
-       CFG_STR("extraargs", "", CFGF_NONE),
-+      CFG_STR("label", "", CFGF_NONE),
-       CFG_STR_LIST("files", 0, CFGF_NONE),
-       CFG_SEC("file", file_opts, CFGF_MULTI | CFGF_TITLE),
-       CFG_END()
--- 
-2.24.0
-
index c1f2270d282a261a375d03afaea67133578e8efb..fb5d23550801f83e81dab0146a1fd73d6e3787b6 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256 2ee024bfb2ec157651b86f3365d138ee013dcc48277d86e1eed6f3285a67b532        genimage-11.tar.xz
+sha256 2e9b43d1288f4e216d6c79de2a0c53ce1bd41f93cec750d8ab057aa2d0b0ee4a        genimage-12.tar.xz
 sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643        COPYING
index 5ef7d301fa046e3bf787669272706f0354a94df6..8960393904a3a1efa3240e66d2925eecf88e5a21 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-GENIMAGE_VERSION = 11
+GENIMAGE_VERSION = 12
 GENIMAGE_SOURCE = genimage-$(GENIMAGE_VERSION).tar.xz
 GENIMAGE_SITE = https://github.com/pengutronix/genimage/releases/download/v$(GENIMAGE_VERSION)
 HOST_GENIMAGE_DEPENDENCIES = host-pkgconf host-libconfuse