lua: fix pkgconfig installation
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 2 May 2010 21:22:45 +0000 (23:22 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 2 May 2010 21:22:45 +0000 (23:22 +0200)
install -D needs the destination filename, not just it's directory,
otherwise we end up with a pkgconfig file instead.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/lua/lua.mk

index 9b2302144957e121cef9a540558402b7ee64bc6b..d66be9fd3ce8afe71e0c2e11ffc85de6e9913cbd 100644 (file)
@@ -39,7 +39,7 @@ endif
 
 define LUA_INSTALL_STAGING_CMDS
        $(INSTALL) -m 0644 -D $(@D)/etc/lua.pc \
-               $(STAGING_DIR)/usr/lib/pkgconfig
+               $(STAGING_DIR)/usr/lib/pkgconfig/lua.pc
        $(INSTALL) $(@D)/src/liblua.a $(STAGING_DIR)/usr/lib
        $(INSTALL) $(@D)/src/lua $(STAGING_DIR)/usr/bin
        $(INSTALL) $(@D)/src/luac $(STAGING_DIR)/usr/bin