boot/optee-os: bump version to 3.7.0
authorEtienne Carriere <etienne.carriere@linaro.org>
Tue, 29 Oct 2019 14:41:27 +0000 (15:41 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 29 Oct 2019 21:25:18 +0000 (22:25 +0100)
Bump OP-TEE OS package version to OP-TEE release 3.7.0.

This adds host-python-pyelftools to optee-os dependencies

Signed-off-by: Etienne Carriere <etienne.carriere@linaro.org>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
boot/optee-os/Config.in
boot/optee-os/optee-os.hash
boot/optee-os/optee-os.mk

index 18b81ab01d1558ef861b31dd6db6e1beab0ec52f..669bbda924ace87f29b197d8f7be1a382c563f12 100644 (file)
@@ -18,7 +18,7 @@ choice
          Select the version of OP-TEE OS you want to use
 
 config BR2_TARGET_OPTEE_OS_LATEST
-       bool "3.5.0"
+       bool "3.7.0"
        help
          Use the latest release tag from the OP-TEE OS official Git
          repository.
@@ -50,7 +50,7 @@ endif
 
 config BR2_TARGET_OPTEE_OS_VERSION
        string
-       default "3.5.0"         if BR2_TARGET_OPTEE_OS_LATEST
+       default "3.7.0"         if BR2_TARGET_OPTEE_OS_LATEST
        default BR2_TARGET_OPTEE_OS_CUSTOM_REPO_VERSION \
                                if BR2_TARGET_OPTEE_OS_CUSTOM_GIT
 
index 1c8f5d6b315f706e867df1d13d404ec34530f7e3..dc0fbecce77a1315d6919dd96b9940b781f78008 100644 (file)
@@ -1,4 +1,4 @@
-# From https://github.com/OP-TEE/optee_os/archive/3.5.0.tar.gz
-sha256 a02fe8e7fdee9653e9207059071735a839b1255fdaf311a2a6cfd185a4cee6a2  optee-os-3.5.0.tar.gz
+# From https://github.com/OP-TEE/optee_os/archive/3.7.0.tar.gz
+sha256 ff378f22b8e7dacf933a2d34eb5c1bdcafe74bdda692e4dbc2969301f6a81d43  optee-os-3.7.0.tar.gz
 # Locally computed
 sha256 1247ee90858f4037b6cac63cbffddfed435d0d73c631b37d78c1e6e6ab3e5d1a  LICENSE
index 28f5add480b78c42c1001a70fd8b22b6e7197c66..bedde85212c2c8636a8f8142b8655a7960bcc066 100644 (file)
@@ -19,7 +19,7 @@ else
 OPTEE_OS_SITE = $(call github,OP-TEE,optee_os,$(OPTEE_OS_VERSION))
 endif
 
-OPTEE_OS_DEPENDENCIES = host-openssl host-python-pycrypto
+OPTEE_OS_DEPENDENCIES = host-openssl host-python-pycrypto host-python-pyelftools
 
 # On 64bit targets, OP-TEE OS can be built in 32bit mode, or
 # can be built in 64bit mode and support 32bit and 64bit