syslog-ng: add optional support for libnet build
authorChris Packham <judge.packham@gmail.com>
Thu, 8 Sep 2016 10:01:17 +0000 (22:01 +1200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 8 Sep 2016 19:56:52 +0000 (21:56 +0200)
If libnet is included pass --enable-spoof-source to configure otherwise
pass --disable-spoof-source. This stops syslog-ng's configure from
enabling address spoofing based on the build host having libnet
installed.

Fixes:

  http://autobuild.buildroot.net/results/71c733e4a7275f3a1b79cd19065d94e77af0309b
  http://autobuild.buildroot.net/results/d16ba0b9ef75d5a676a26db788be31556b69772a
  http://autobuild.buildroot.net/results/9659d1db1a128b269459fd9b8be797a9efbd35af

Signed-off-by: Chris Packham <judge.packham@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/syslog-ng/syslog-ng.mk

index c11d3bde4933e94a00ab2d300ae7b32a0a0d0df7..7e4d4076175c436f89440fedad08e2f7898ce7ea 100644 (file)
@@ -69,6 +69,13 @@ ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID),y)
 SYSLOG_NG_DEPENDENCIES += util-linux
 endif
 
+ifeq ($(BR2_PACKAGE_LIBNET),y)
+SYSLOG_NG_DEPENDENCIES += libnet
+SYSLOG_NG_CONF_OPTS += --enable-spoof-source
+else
+SYSLOG_NG_CONF_OPTS += --disable-spoof-source
+endif
+
 ifeq ($(BR2_INIT_SYSTEMD),y)
 SYSLOG_NG_DEPENDENCIES += systemd
 SYSLOG_NG_CONF_OPTS += \