imx-gpu-viv: enable package for 64-bit i.MX processors
authorGary Bisson <gary.bisson@boundarydevices.com>
Tue, 12 Jun 2018 15:02:19 +0000 (17:02 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 17 Jun 2018 13:24:09 +0000 (15:24 +0200)
Basically enabling the package for aarch64. One difference with 32-bit
i.MX platforms resides in the fact that Wayland is the only back-end
supported. Therefore X11 and Framebuffer options are masked.

This was tested on i.MX8MQ Nitrogen8M platform (with weston-imx):
 # cd /usr/share/examples/viv_samples/vdk/
 # ./tutorial7

Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com>
[Thomas: drop BR2_PACKAGE_FREESCALE_IMX_HAS_VIV_GPU_WAYLAND_ONLY and
use BR2_PACKAGE_FREESCALE_IMX_PLATFORM_IMX8M directly.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/freescale-imx/Config.in
package/freescale-imx/imx-gpu-viv/Config.in
package/freescale-imx/imx-gpu-viv/imx-gpu-viv.hash
package/freescale-imx/imx-gpu-viv/imx-gpu-viv.mk

index 97aeb15764e4331cc72f23b7471bbb9a45699ec1..30e71b825f4eaf1e4036dfdf6058178986b4dce8 100644 (file)
@@ -69,7 +69,8 @@ config BR2_PACKAGE_FREESCALE_IMX_HAS_VIV_GPU
        bool
        default y if BR2_PACKAGE_FREESCALE_IMX_PLATFORM_IMX6Q || \
                BR2_PACKAGE_FREESCALE_IMX_PLATFORM_IMX6S || \
-               BR2_PACKAGE_FREESCALE_IMX_PLATFORM_IMX7
+               BR2_PACKAGE_FREESCALE_IMX_PLATFORM_IMX7 || \
+               BR2_PACKAGE_FREESCALE_IMX_PLATFORM_IMX8M
 
 source "package/freescale-imx/imx-alsa-plugins/Config.in"
 source "package/freescale-imx/imx-codec/Config.in"
index 4e753a41f35d5260e826aa26f93ee5c1f200319c..a2deaf2e12a5365c5450a816ca6b51b191fa8eca 100644 (file)
@@ -2,10 +2,14 @@ comment "imx-gpu-viv needs a glibc toolchain with armhf enabled"
        depends on BR2_arm
        depends on !BR2_TOOLCHAIN_USES_GLIBC || !BR2_ARM_EABIHF
 
+comment "imx-gpu-viv needs a glibc toolchain"
+       depends on BR2_aarch64
+       depends on !BR2_TOOLCHAIN_USES_GLIBC
+
 config BR2_PACKAGE_IMX_GPU_VIV
        bool "imx-gpu-viv"
        # Pre-built binaries only available for ARM EABIhf
-       depends on BR2_ARM_EABIHF
+       depends on (BR2_arm && BR2_ARM_EABIHF) || BR2_aarch64
        # Library binaries are linked against libc.so.6
        depends on BR2_TOOLCHAIN_USES_GLIBC
        select BR2_PACKAGE_HAS_LIBEGL
@@ -34,15 +38,20 @@ choice
 config BR2_PACKAGE_IMX_GPU_VIV_OUTPUT_X11
        bool "X11"
        depends on BR2_PACKAGE_XORG7
+       # The i.MX8 blob doesn't support X11 output
+       depends on !BR2_PACKAGE_FREESCALE_IMX_PLATFORM_IMX8M
        select BR2_PACKAGE_XLIB_LIBXDAMAGE
        select BR2_PACKAGE_XLIB_LIBXEXT
        select BR2_PACKAGE_XLIB_LIBXFIXES
 
 comment "X11 backend needs Xorg package"
        depends on !BR2_PACKAGE_XORG7
+       depends on !BR2_PACKAGE_FREESCALE_IMX_PLATFORM_IMX8M
 
 config BR2_PACKAGE_IMX_GPU_VIV_OUTPUT_FB
        bool "Framebuffer"
+       # The i.MX8 blob doesn't support FB output
+       depends on !BR2_PACKAGE_FREESCALE_IMX_PLATFORM_IMX8M
 
 config BR2_PACKAGE_IMX_GPU_VIV_OUTPUT_WL
        bool "Wayland"
index 3b54eec09952ca6178bbe51ca947ecd8e33e01dd..2cbc36a18548ffd4c7f8c508adb2206cc5b9a870 100644 (file)
@@ -1 +1,2 @@
 sha256 dddadd164bede4793409ccfb636324dd73862c33458db66a5860f126bada25dc  imx-gpu-viv-6.2.4.p1.2-aarch32.bin
+sha256 27ed3f58681cef18f87ea20946cc89b2cef4848006064303d20583e6ed7aeec7  imx-gpu-viv-6.2.4.p1.2-aarch64.bin
index 35ff9d457c49358d6500dc9590217090e970cdc3..511e3b3b6cd4ca151a42da0a8c718bd32092e8e3 100644 (file)
@@ -4,7 +4,11 @@
 #
 ################################################################################
 
+ifeq ($(BR2_aarch64),y)
+IMX_GPU_VIV_VERSION = 6.2.4.p1.2-aarch64
+else
 IMX_GPU_VIV_VERSION = 6.2.4.p1.2-aarch32
+endif
 IMX_GPU_VIV_SITE = $(FREESCALE_IMX_SITE)
 IMX_GPU_VIV_SOURCE = imx-gpu-viv-$(IMX_GPU_VIV_VERSION).bin