Applied patch from Michel Wilson to allow the cursor in the X root window to
authorHamish Moffatt <hamish@cloud.net.au>
Wed, 10 Sep 2008 13:16:23 +0000 (13:16 -0000)
committerHamish Moffatt <hamish@cloud.net.au>
Wed, 10 Sep 2008 13:16:23 +0000 (13:16 -0000)
be disabled. Unfortunately this is a compile-time option.

package/x11r7/xserver_xorg-server/Config.in
package/x11r7/xserver_xorg-server/xserver_xorg-server.mk

index f50b21e36ee115519f6da3968721a5ad58192ad1..720ae3163154daa205532dde591bb8217e5fe924 100644 (file)
@@ -52,3 +52,9 @@ config BR2_PACKAGE_XSERVER_XORG_SERVER
        help
          xorg-server 1.4
          No description available
+
+config BR2_PACKAGE_XSERVER_XORG_SERVER_NULL_CURSOR
+    bool "Null root cursor"
+    depends on BR2_PACKAGE_XSERVER_XORG_SERVER
+    help
+        Don't display root cursor.
index 72c5108016db66fb8390f4546dae11943561d3a3..e7c8758b1524b88f40a14f70d7085de163465e6b 100644 (file)
@@ -24,6 +24,12 @@ else
 XSERVER_XORG_ENABLE_KDRIVE:=--disable-kdrive --disable-xfbdev
 endif
 
+ifeq ($(strip $(BR2_PACKAGE_XSERVER_XORG_SERVER_NULL_CURSOR)),y)
+XSERVER_XORG_NULL_CURSOR:=--enable-null-root-cursor
+else
+XSERVER_XORG_NULL_CURSOR:=--disable-null-root-cursor
+endif
+
 XSERVER_XORG_SERVER_DEPENDENCIES =  freetype xutil_util-macros xlib_libXfont libdrm xlib_libxkbui \
                                                                        xproto_compositeproto xproto_damageproto xproto_fixesproto \
                                                                        xproto_glproto xproto_kbproto xproto_randrproto freetype \
@@ -42,6 +48,7 @@ XSERVER_XORG_SERVER_CONF_OPT = $(XSERVER_XORG_ENABLE_KDRIVE) \
                --enable-freetype $(XSERVER_XORG_ENABLE_MODULAR) \
                --disable-config-hal $(XSERVER_XORG_MESA_DIR) \
                --disable-xnest --disable-xephyr --disable-xvfb \
+               $(XSERVER_XORG_NULL_CURSOR)
                CFLAGS="-I$(STAGING_DIR)/usr/include/pixman-1"
 
 XSERVER_XORG_SERVER_INSTALL_STAGING_OPT = DESTDIR=$(STAGING_DIR) install install-data