lpc32xxcdl: fix patch step
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 2 Feb 2012 15:02:48 +0000 (16:02 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 2 Feb 2012 15:02:48 +0000 (16:02 +0100)
The lpc32xxcdl files have dos newlines, which our patch infrastructure
doesn't handle. Work around it by converting the affected files to unix
newlines before patching.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
boot/lpc32xxcdl/lpc32xxcdl.mk

index 80f3493a2e67194b4ab67f5f28d09780c3955593..d11be6cf2c8c53fc10b8f47a312be7731bfba98f 100644 (file)
@@ -42,6 +42,16 @@ LPC32XXCDL_BUILD_FLAGS = \
 LPC32XXCDL_BOARD_STARTUP_DIR = \
        csps/lpc32xx/bsps/$(BR2_TARGET_LPC32XXCDL_BOARDNAME)/startup/examples/
 
+# Source files are with dos newlines, which our patch infrastructure doesn't
+# handle. Work around it by converting the affected files to unix newlines
+# before patching
+define LPC32XXCDL_DOS2UNIX_FOR_PATCH
+       sed -n 's|^[+-]\{3\} [^/]\+\([^ \t]*\)\(.*\)|$(@D)\1|p' \
+               boot/lpc32xxcdl/*.patch| sort -u | xargs $(SED) 's/\x0D$$//'
+endef
+
+LPC32XXCDL_POST_EXTRACT_HOOKS += LPC32XXCDL_DOS2UNIX_FOR_PATCH
+
 define LPC32XXCDL_BUILD_CMDS
        $(MAKE1) $(LPC32XXCDL_BUILD_FLAGS) -C $(@D)
        $(MAKE1) $(LPC32XXCDL_BUILD_FLAGS) -C $(@D)/$(LPC32XXCDL_BOARD_STARTUP_DIR)/Burners/$(LPC32XXCDL_KICKSTART_BURNER)