libcurl: compile with openssl support if available
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 28 Dec 2008 20:04:01 +0000 (20:04 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 28 Dec 2008 20:04:01 +0000 (20:04 -0000)
package/libcurl/libcurl-7.19.2-fix-ssl-no-verbose.patch [new file with mode: 0644]
package/libcurl/libcurl.mk

diff --git a/package/libcurl/libcurl-7.19.2-fix-ssl-no-verbose.patch b/package/libcurl/libcurl-7.19.2-fix-ssl-no-verbose.patch
new file mode 100644 (file)
index 0000000..b15ed96
--- /dev/null
@@ -0,0 +1,25 @@
+ssluse.c: fix build breakage with --with-ssl --disable-verbose
+
+Revision 1.206 of ssluse.c removed the prefix argument to asn1_output,
+but it is still referenced in the CURL_DISABLE_VERBOSE_STRINGS case.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ lib/ssluse.c |    4 ----
+ 1 file changed, 4 deletions(-)
+
+Index: curl-7.19.2/lib/ssluse.c
+===================================================================
+--- curl-7.19.2.orig/lib/ssluse.c
++++ curl-7.19.2/lib/ssluse.c
+@@ -923,10 +923,6 @@
+   int i;
+   int year=0,month=0,day=0,hour=0,minute=0,second=0;
+-#ifdef CURL_DISABLE_VERBOSE_STRINGS
+-  (void)prefix;
+-#endif
+-
+   i=tm->length;
+   asn1_string=(const char *)tm->data;
index 60ed3623db99f33e53a0fac680a4b1f104c1216e..32840044910d0e6235c27112fe31a150d62777db 100644 (file)
@@ -10,6 +10,12 @@ LIBCURL_INSTALL_STAGING = YES
 LIBCURL_CONF_OPT = --disable-verbose --disable-manual --enable-hidden-symbols \
                   $(DISABLE_NLS) $(DISABLE_LARGEFILE) $(DISABLE_IPV6)
 
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+LIBCURL_DEPENDENCIES += openssl
+LIBCURL_CONF_ENV += ac_cv_lib_crypto_CRYPTO_lock=yes
+LIBCURL_CONF_OPT += --with-ssl=$(STAGING_DIR)/usr --with-random=/dev/urandom
+endif
+
 $(eval $(call AUTOTARGETS,package,libcurl))
 
 $(LIBCURL_HOOK_POST_INSTALL):