ghostscript: needs host-zlib
authorRodrigo Rebello <rprebello@gmail.com>
Sun, 26 Mar 2017 20:00:17 +0000 (17:00 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 26 Mar 2017 20:36:23 +0000 (22:36 +0200)
The ghostscript configure script checks for zlib on the host when
configuring the build of auxiliary programs used in the compilation
process and fails if such library is not found.

Add 'host-zlib' as a dependency and, while at it, also enclose $(HOSTCC)
in double quotes, otherwise configure fails when that variable expands
to a command containing spaces (e.g. when ccache is enabled).

Fixes:

  http://autobuild.buildroot.net/results/61af9caa7fe6fce6b11f78f66b9d3590f37e92e7/
  http://autobuild.buildroot.net/results/904f06e14247c22f740d8fd8902618017e0518f6/

Signed-off-by: Rodrigo Rebello <rprebello@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ghostscript/ghostscript.mk

index e568b2047563544dd161828f4219149264bfa48e..265503e471a10f8039275c2d698743beb41ae2e1 100644 (file)
@@ -15,6 +15,7 @@ GHOSTSCRIPT_DEPENDENCIES = \
        host-lcms2 \
        host-libjpeg \
        host-pkgconf \
+       host-zlib \
        fontconfig \
        ghostscript-fonts \
        jpeg \
@@ -31,7 +32,7 @@ endef
 GHOSTSCRIPT_POST_PATCH_HOOKS += GHOSTSCRIPT_REMOVE_LIBS
 
 GHOSTSCRIPT_CONF_ENV = \
-       CCAUX=$(HOSTCC) \
+       CCAUX="$(HOSTCC)" \
        CFLAGSAUX="$(HOST_CFLAGS) $(HOST_LDFLAGS)"
 
 GHOSTSCRIPT_CONF_OPTS = \