package/python-pathlib2: New package
authorAndrey Smirnov <andrew.smirnov@gmail.com>
Mon, 12 Jun 2017 23:42:12 +0000 (16:42 -0700)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 15 Jun 2017 20:49:58 +0000 (22:49 +0200)
Add 'pathlib2'[1] package to Buildroot. Needed by 'pickleshare'
package, which is added in the next patch.

[1] https://pypi.python.org/pypi/pathlib2

Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
DEVELOPERS
package/Config.in
package/python-pathlib2/Config.in [new file with mode: 0644]
package/python-pathlib2/python-pathlib2.hash [new file with mode: 0644]
package/python-pathlib2/python-pathlib2.mk [new file with mode: 0644]

index 9d5f51b08b0193f5bf2bb8735beca77edbb12678..3a7391779743eb04d34f1b0c7d3253c0b528cba1 100644 (file)
@@ -83,6 +83,7 @@ F:    package/wine/
 N:     Andrey Smirnov <andrew.smirnov@gmail.com>
 F:     package/python-decorator/
 F:     package/python-ipython-genutils/
+F:     package/python-pathlib2/
 F:     package/python-scandir/
 F:     package/python-simplegeneric/
 F:     package/python-traitlets/
index 14315d5ca68f511c834a2a3ca1ea53dc1f55b9d0..cf41b37ed560a44805be890881faadf3c2bc4129 100644 (file)
@@ -773,6 +773,7 @@ menu "External python modules"
        source "package/python-paho-mqtt/Config.in"
        source "package/python-pam/Config.in"
        source "package/python-paramiko/Config.in"
+       source "package/python-pathlib2/Config.in"
        source "package/python-pathpy/Config.in"
        source "package/python-pathtools/Config.in"
        source "package/python-pathvalidate/Config.in"
diff --git a/package/python-pathlib2/Config.in b/package/python-pathlib2/Config.in
new file mode 100644 (file)
index 0000000..7297f0a
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_PYTHON_PATHLIB2
+       bool "python-pathlib2"
+       depends on BR2_PACKAGE_PYTHON
+       select BR2_PACKAGE_PYTHON_SIX # runtime
+       select BR2_PACKAGE_PYTHON_SCANDIR # runtime
+       help
+         Object-oriented filesystem paths.
+
+         The goal of pathlib2 is to provide a backport of standard
+         pathlib module which tracks the standard library module, so
+         all the newest features of the standard pathlib can be used
+         also on older Python versions.
+
+         https://pypi.python.org/pypi/pathlib2
diff --git a/package/python-pathlib2/python-pathlib2.hash b/package/python-pathlib2/python-pathlib2.hash
new file mode 100644 (file)
index 0000000..a9c2949
--- /dev/null
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi/pathlib2/json, sha256 locally computed
+md5 6c75bfde898b6c88627621a48ee8de14 pathlib2-2.2.1.tar.gz
+sha256 ce9007df617ef6b7bd8a31cd2089ed0c1fed1f7c23cf2bf1ba140b3dd563175d pathlib2-2.2.1.tar.gz
diff --git a/package/python-pathlib2/python-pathlib2.mk b/package/python-pathlib2/python-pathlib2.mk
new file mode 100644 (file)
index 0000000..db2df91
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-pathlib2
+#
+################################################################################
+
+PYTHON_PATHLIB2_VERSION = 2.2.1
+PYTHON_PATHLIB2_SOURCE = pathlib2-$(PYTHON_PATHLIB2_VERSION).tar.gz
+PYTHON_PATHLIB2_SITE = https://pypi.python.org/packages/ab/d8/ac7489d50146f29d0a14f65545698f4545d8a6b739b24b05859942048b56
+PYTHON_PATHLIB2_LICENSE = MIT
+PYTHON_PATHLIB2_LICENSE_FILE = LICENSE.rst
+PYTHON_PATHLIB2_SETUP_TYPE = setuptools
+
+$(eval $(python-package))