perl-module-implementation: new package
authorChristopher McCrory <chrismcc@gmail.com>
Sat, 11 Aug 2018 18:27:42 +0000 (11:27 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 13 Aug 2018 21:16:01 +0000 (23:16 +0200)
Signed-off-by: Christopher McCrory <chrismcc@gmail.com>
Acked-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/perl-module-implementation/Config.in [new file with mode: 0644]
package/perl-module-implementation/perl-module-implementation.hash [new file with mode: 0644]
package/perl-module-implementation/perl-module-implementation.mk [new file with mode: 0644]

index 6d0e3ecceb829605612c3f2ec32b59e943f22173..f96a18a5f71d2599d021ae661330cd9438a87a85 100644 (file)
@@ -495,6 +495,7 @@ F:  package/perl-io-interface/
 F:     package/perl-io-socket-multicast/
 F:     package/perl-json-maybexs/
 F:     package/perl-mime-tools/
+F:     package/perl-module-implementation/
 F:     package/perl-module-runtime/
 F:     package/perl-number-bytes-human/
 F:     package/perl-params-util/
index 85046ae56e7e6c841cfc573e232dd4361c46af41..7a7142802a6912df47fadf13368475c313e6fdd2 100644 (file)
@@ -711,6 +711,7 @@ menu "Perl libraries/modules"
        source "package/perl-mime-base64-urlsafe/Config.in"
        source "package/perl-mime-base64/Config.in"
        source "package/perl-mime-tools/Config.in"
+       source "package/perl-module-implementation/Config.in"
        source "package/perl-module-runtime/Config.in"
        source "package/perl-mojolicious-plugin-authentication/Config.in"
        source "package/perl-mojolicious/Config.in"
diff --git a/package/perl-module-implementation/Config.in b/package/perl-module-implementation/Config.in
new file mode 100644 (file)
index 0000000..3541976
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_PERL_MODULE_IMPLEMENTATION
+       bool "perl-module-implementation"
+       select BR2_PACKAGE_PERL_MODULE_RUNTIME
+       select BR2_PACKAGE_PERL_TRY_TINY
+       help
+         Loads one of several alternate underlying implementations
+         for a module
+
+         http://metacpan.org/release/Module-Implementation
diff --git a/package/perl-module-implementation/perl-module-implementation.hash b/package/perl-module-implementation/perl-module-implementation.hash
new file mode 100644 (file)
index 0000000..caf365c
--- /dev/null
@@ -0,0 +1,6 @@
+# retrieved by scancpan from http://cpan.metacpan.org/
+md5    52e3fe0ca6b1eff0488d59b7aacc0667 Module-Implementation-0.09.tar.gz
+sha256 c15f1a12f0c2130c9efff3c2e1afe5887b08ccd033bd132186d1e7d5087fd66d Module-Implementation-0.09.tar.gz
+
+# computed by scancpan
+sha256 dd34e4dbcadfaa3db992201873e1cbb4b4f4c18e9bf000821d5c768e66d7ff0b LICENSE
diff --git a/package/perl-module-implementation/perl-module-implementation.mk b/package/perl-module-implementation/perl-module-implementation.mk
new file mode 100644 (file)
index 0000000..50ee861
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# perl-module-implementation
+#
+################################################################################
+
+PERL_MODULE_IMPLEMENTATION_VERSION = 0.09
+PERL_MODULE_IMPLEMENTATION_SOURCE = Module-Implementation-$(PERL_MODULE_IMPLEMENTATION_VERSION).tar.gz
+PERL_MODULE_IMPLEMENTATION_SITE = $(BR2_CPAN_MIRROR)/authors/id/D/DR/DROLSKY
+PERL_MODULE_IMPLEMENTATION_DEPENDENCIES = perl-module-runtime perl-try-tiny
+PERL_MODULE_IMPLEMENTATION_LICENSE = Artistic-2.0
+PERL_MODULE_IMPLEMENTATION_LICENSE_FILES = LICENSE
+
+$(eval $(perl-package))