package/libdvbsi: new package
authorCarsten Schoenert <c.schoenert@gmail.com>
Sun, 23 Jun 2013 15:30:33 +0000 (17:30 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 27 Jun 2013 19:30:52 +0000 (21:30 +0200)
libdvbsi++ is a C++ library for parsing DVB SI sections and providing
the output in C++ objects. It's usefull in any case you need prepared
and preselected DVB SI data from the raw stream.

[Peter: fix _LICENSE_FILES tag]
Signed-off-by: Carsten Schoenert <c.schoenert@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/libdvbsi/Config.in [new file with mode: 0644]
package/libdvbsi/libdvbsi.mk [new file with mode: 0644]

index 5ab85a3ff3cf2c1db5c6d5579d4d1a3c39e20603..ebeabeb1a7ed63f3530ca5fce110876f87dfc92e 100644 (file)
@@ -516,6 +516,7 @@ source "package/json-javascript/Config.in"
 endmenu
 
 menu "Multimedia"
+source "package/libdvbsi/Config.in"
 source "package/libdvdread/Config.in"
 source "package/libdvdnav/Config.in"
 source "package/libebml/Config.in"
diff --git a/package/libdvbsi/Config.in b/package/libdvbsi/Config.in
new file mode 100644 (file)
index 0000000..0d3143f
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_LIBDVBSI
+       bool "libdvbsi"
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_USE_WCHAR
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       help
+         C++ parsing library for Service Information (SI) in DVB systems.
+         With libdvbsi++ you can convert raw DVB service information to
+         a set of C++ objects, removing the need to parse data manually.
+
+         http://www.saftware.de/
+
+comment "libdvbsi++ requires a toolchain with C++, WCHAR and threads support"
+       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/libdvbsi/libdvbsi.mk b/package/libdvbsi/libdvbsi.mk
new file mode 100644 (file)
index 0000000..3e99177
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# libdvbsi++
+#
+################################################################################
+
+LIBDVBSI_VERSION = 0.3.6
+LIBDVBSI_SOURCE = libdvbsi++-$(LIBDVBSI_VERSION).tar.bz2
+LIBDVBSI_SITE = http://www.saftware.de/libdvbsi++
+LIBDVBSI_INSTALL_STAGING = YES
+LIBDVBSI_LICENSE = LGPLv2.1
+LIBDVBSI_LICENSE_FILES = COPYING
+
+# sometimes no Makefile is in the archive, just (re)generate
+LIBDVBSI_AUTORECONF=YES
+
+$(eval $(autotools-package))