wpa_supplicant: detect readline support in wpa_cli
authorOscar Hellström <oscar.hellstrom@vinnter.se>
Mon, 12 May 2014 16:16:09 +0000 (18:16 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 13 May 2014 07:26:45 +0000 (09:26 +0200)
Signed-off-by: Oscar Hellström <oscar.hellstrom@vinnter.se>
Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/wpa_supplicant/wpa_supplicant.mk

index 9fcda2e449323a7c2b651e71264a8fa4be1860bd..9321f089a66bebc9dc1f4dcd580f57360af8431a 100644 (file)
@@ -105,6 +105,11 @@ define WPA_SUPPLICANT_DEBUG_CONFIG
 endef
 endif
 
+ifeq ($(BR2_PACKAGE_READLINE),y)
+       WPA_SUPPLICANT_DEPENDENCIES += readline
+       WPA_SUPPLICANT_CONFIG_ENABLE += CONFIG_READLINE
+endif
+
 define WPA_SUPPLICANT_CONFIGURE_CMDS
        cp $(@D)/wpa_supplicant/defconfig $(WPA_SUPPLICANT_CONFIG)
        sed -i $(patsubst %,-e 's/^#\(%\)/\1/',$(WPA_SUPPLICANT_CONFIG_ENABLE)) \