cairo: disable trace and trace interpreter
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 14 Oct 2012 00:28:37 +0000 (00:28 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 14 Oct 2012 18:18:03 +0000 (20:18 +0200)
The Cairo tracing and trace interpreter are most likely not that
useful, so disable them. They also require zlib, which isn't a
dependency of Cairo at the moment. This fixes the following build
failure:

  http://autobuild.buildroot.org/results/a91e4e337fd9deb0f9fad433350feb27b2aee556/build-end.log

In the future, if people are interested by the trace and trace
interpreter, we can add a new Config.in knob for them.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/cairo/cairo.mk

index eedb28d0e4f8e8c6380cb1a4c1ec9dd295af9c04..2a453bbc23155f2ddd07e03681f0f7ff3012786a 100644 (file)
@@ -34,6 +34,10 @@ CAIRO_CONF_ENV = ac_cv_func_posix_getpwuid_r=yes glib_cv_stack_grows=no \
                ac_cv_func_working_mktime=yes jm_cv_func_working_re_compile_pattern=yes \
                ac_use_included_regex=no gl_cv_c_restrict=no
 
+CAIRO_CONF_OPT = \
+       --enable-trace=no \
+       --enable-interpreter=no
+
 CAIRO_DEPENDENCIES = host-pkg-config fontconfig pixman
 
 ifeq ($(BR2_PACKAGE_DIRECTFB),y)