pkg-autotools: use $(HOST_DIR) instead of $(HOST_DIR)/usr as prefix
authorArnout Vandecappelle <arnout@mind.be>
Tue, 4 Jul 2017 14:03:59 +0000 (16:03 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 5 Jul 2017 09:49:08 +0000 (11:49 +0200)
Remove the redundant usr/ component of the HOST_DIR paths. Since a
previous commit added a symlink from $(HOST_DIR)/usr to $(HOST_DIR),
everything keeps on working.

Build-tested with a bunch of autotools packages.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Reviewed-by: Romain Naour <romain.naour@smile.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-autotools.mk

index ba1f4d9764e81d8fb0031ba2b09764736d70910d..45de99356f5fd363c474109f6aa3e7edd7e6ed39 100644 (file)
@@ -220,7 +220,7 @@ define $(2)_CONFIGURE_CMDS
        $$($$(PKG)_CONF_ENV) \
        CONFIG_SITE=/dev/null \
        ./configure \
-               --prefix="$$(HOST_DIR)/usr" \
+               --prefix="$$(HOST_DIR)" \
                --sysconfdir="$$(HOST_DIR)/etc" \
                --localstatedir="$$(HOST_DIR)/var" \
                --enable-shared --disable-static \