package/busybox: add /bin/{a, hu}sh to /etc/shells
authorRomain Naour <romain.naour@smile.fr>
Fri, 19 Jan 2018 10:15:02 +0000 (11:15 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 3 May 2018 21:12:20 +0000 (23:12 +0200)
When ash (busybox) is selected, /bin/{a,hu}sh is not added to /etc/shells
(see man shells). So, login tools like dropbear reject the ssh
connections for users using {a,hu}sh as shell in /etc/passwd.

buildroot authpriv.warn dropbear[853]: User 'kubu' has invalid shell, rejected

Signed-off-by: Romain Naour <romain.naour@smile.fr>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/busybox/busybox.mk

index fd4ac600c2c40c3a93b0732c5d5e502701faa7e6..60a55a2c78a04ab55ed58bb54b508aaaf5d542a5 100644 (file)
@@ -262,6 +262,20 @@ define BUSYBOX_INSTALL_TELNET_SCRIPT
        fi
 endef
 
+# Add /bin/{a,hu}sh to /etc/shells otherwise some login tools like dropbear
+# can reject the user connection. See man shells.
+define BUSYBOX_INSTALL_ADD_TO_SHELLS
+       if grep -q CONFIG_ASH=y $(@D)/.config; then \
+               grep -qsE '^/bin/ash$$' $(TARGET_DIR)/etc/shells \
+               || echo "/bin/ash" >> $(TARGET_DIR)/etc/shells; \
+       fi
+       if grep -q CONFIG_HUSH=y $(@D)/.config; then \
+               grep -qsE '^/bin/hush$$' $(TARGET_DIR)/etc/shells \
+               || echo "/bin/hush" >> $(TARGET_DIR)/etc/shells; \
+       fi
+endef
+BUSYBOX_TARGET_FINALIZE_HOOKS += BUSYBOX_INSTALL_ADD_TO_SHELLS
+
 # Enable "noclobber" in install.sh, to prevent BusyBox from overwriting any
 # full-blown versions of apps installed by other packages with sym/hard links.
 define BUSYBOX_NOCLOBBER_INSTALL