libsodium: disable PIE on ARC
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>
Mon, 10 Aug 2015 11:24:50 +0000 (14:24 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 10 Aug 2015 13:04:47 +0000 (15:04 +0200)
Even though ARC gcc understands "-pie" option and attempts to generate
PIE binaries as of today PIE is not really supported for user-space
applications.

So we disable PIE detection if building for ARC.
That fixes http://autobuild.buildroot.net/results/be4/be46b621ce5443788b0a1bc9fab614c4ca5d0859
and also prevents execution of non-supported PIE binary in runtime.

Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libsodium/libsodium.mk

index c0328639691334498fde7fc23e8db407e1d7a69f..18035f337968b9189a02ab3623e01c5b62d35685 100644 (file)
@@ -10,4 +10,8 @@ LIBSODIUM_LICENSE = ISC
 LIBSODIUM_LICENSE_FILES = LICENSE
 LIBSODIUM_INSTALL_STAGING = YES
 
+ifeq ($(BR2_arc),y)
+LIBSODIUM_CONF_OPTS += --disable-pie
+endif
+
 $(eval $(autotools-package))