- andersee, why was this duplicated and hardcoded here?
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Mon, 15 Jan 2007 17:34:58 +0000 (17:34 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Mon, 15 Jan 2007 17:34:58 +0000 (17:34 -0000)
target/device/x86/i386/linux26.mk

index f6a33fadb159898333f3c5495d30ebcaf04b3ce7..2022200360e699a88087f2560614fa756f4bc282 100644 (file)
@@ -6,12 +6,15 @@
 ifneq ($(filter $(TARGETS),linux26),)
 
 
+ifeq ($(LINUX_HEADERS_VERSION),)
 # Version of Linux to download and then apply patches to
 DOWNLOAD_LINUX26_VERSION=2.6.19.1
 # Version of Linux after applying any patches
 LINUX26_VERSION=2.6.19.1
-
-
+else
+DOWNLOAD_LINUX26_VERSION=$(LINUX_HEADERS_VERSION)
+LINUX26_VERSION=$(LINUX_HEADERS_VERSION)
+endif
 
 LINUX26_SOURCE=linux-$(DOWNLOAD_LINUX26_VERSION).tar.bz2
 LINUX26_BZCAT:=$(BZCAT)