sqlite: do not assume thread support is available
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 18 Jul 2012 07:48:24 +0000 (09:48 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 18 Jul 2012 07:48:24 +0000 (09:48 +0200)
The --enable-threadsafe option was unconditionally passed, without
taking into account whether the underlying toolchain had thread
support or not. Now, we properly pass --enable-threadsafe or
--disable-threadsafe depending on the availability of thread support.

Fixes
http://autobuild.buildroot.net/results/defdc098cff293baabf2f89587476eba71f1c0d0/build-end.log.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/sqlite/sqlite.mk

index 5b85ecc5fd4c28cc7ed44698ca2aeb8677c4a0f4..9e63b521dcf5caa2ee1ff939556f6fe87a24c00e 100644 (file)
@@ -23,9 +23,14 @@ endif
 SQLITE_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) $(SQLITE_CFLAGS)"
 
 SQLITE_CONF_OPT = \
-       --enable-threadsafe \
        --localstatedir=/var
 
+ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
+SQLITE_CONF_OPT += --enable-threadsafe
+else
+SQLITE_CONF_OPT += --disable-threadsafe
+endif
+
 ifeq ($(BR2_PACKAGE_SQLITE_READLINE),y)
 SQLITE_DEPENDENCIES += ncurses readline
 SQLITE_CONF_OPT += --with-readline-inc="-I$(STAGING_DIR)/usr/include"