openssl: fix runtime failure on some powerpc variants
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 7 Dec 2012 02:06:20 +0000 (02:06 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 10 Dec 2012 21:29:03 +0000 (22:29 +0100)
OpenSSL's assembly optimizations por PowerPC seem to be broken for at
least 4xx cores.
Thanks go to Jan Schunke for reporting and testing.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/openssl/openssl.mk

index 265a4fbe8af0f6852b4638448ff244b0d4c8f16e..160df2e5c33d50dfa1958fad2023374023b838c5 100644 (file)
@@ -38,8 +38,11 @@ endif
 endif
 endif
 ifeq ($(ARCH),powerpc)
+# 4xx cores seem to have trouble with openssl's ASM optimizations
+ifeq ($(BR2_powerpc_401)$(BR2_powerpc_403)$(BR2_powerpc_405)$(BR2_powerpc_405fp)$(BR2_powerpc_440)$(BR2_powerpc_440fp),)
        OPENSSL_TARGET_ARCH = ppc
 endif
+endif
 ifeq ($(ARCH),x86_64)
        OPENSSL_TARGET_ARCH = x86_64
 endif