python-enum: new package
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 15 Dec 2014 14:32:12 +0000 (15:32 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 20 Dec 2014 20:56:48 +0000 (21:56 +0100)
This is an alternative to python-enum34 with a somewhat different API.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-enum/Config.in [new file with mode: 0644]
package/python-enum/python-enum.hash [new file with mode: 0644]
package/python-enum/python-enum.mk [new file with mode: 0644]

index 81bb9e3fab0b55b2d6684f9645297ac904039898..0ce890d938be7019b2751aad179349deb9510dd7 100644 (file)
@@ -496,6 +496,7 @@ menu "external python modules"
        source "package/python-dialog/Config.in"
        source "package/python-docopt/Config.in"
        source "package/python-dpkt/Config.in"
+       source "package/python-enum/Config.in"
        source "package/python-enum34/Config.in"
        source "package/python-flask/Config.in"
        source "package/python-flup/Config.in"
diff --git a/package/python-enum/Config.in b/package/python-enum/Config.in
new file mode 100644 (file)
index 0000000..e26ae8b
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_PYTHON_ENUM
+       bool "python-enum"
+       depends on BR2_PACKAGE_PYTHON
+       help
+         Robust enumerated type support in Python
+
+         An enumeration object is an immutable sequence object built
+         from a sequence of strings. Each value is also available as
+         an attribute. Such values are constant. Comparisons and
+         enumeration are supported.
+
+         https://pypi.python.org/pypi/enum
diff --git a/package/python-enum/python-enum.hash b/package/python-enum/python-enum.hash
new file mode 100644 (file)
index 0000000..c7c1924
--- /dev/null
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi?:action=show_md5&digest=ce75c7c3c86741175a84456cc5bd531e, sha256 locally computed
+md5    ce75c7c3c86741175a84456cc5bd531e  enum-0.4.4.tar.gz
+sha256 9bdfacf543baf2350df7613eb37f598a802f346985ca0dc1548be6494140fdff  enum-0.4.4.tar.gz
diff --git a/package/python-enum/python-enum.mk b/package/python-enum/python-enum.mk
new file mode 100644 (file)
index 0000000..0131be3
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-enum
+#
+################################################################################
+
+PYTHON_ENUM_VERSION = 0.4.4
+PYTHON_ENUM_SOURCE = enum-$(PYTHON_ENUM_VERSION).tar.gz
+PYTHON_ENUM_SITE = http://pypi.python.org/packages/source/e/enum
+PYTHON_ENUM_SETUP_TYPE = setuptools
+PYTHON_ENUM_LICENSE = GPLv2+ or Python software foundation license v2
+PYTHON_ENUM_LICENSE_FILES = LICENSE.GPL LICENSE.PSF
+
+$(eval $(python-package))