boost: enable boost-atomic
authorNoé Rubinstein <nrubinstein@aldebaran.com>
Thu, 12 Mar 2015 09:44:24 +0000 (10:44 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 13 Mar 2015 22:13:31 +0000 (23:13 +0100)
It was disabled in february 2013 by commit
e5434583badf1abf4a4620efa76452638ad9e177
because did not build correctly with ucLibc at the time.

It now builds correctly with both uClibc v0.9.33 and uClibc-ng.

Signed-off-by: Noé Rubinstein <nrubinstein@aldebaran.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/boost/Config.in
package/boost/boost.mk

index a15b849d1089993fe63a83f65baff5f28fc37478..574f51ae7e842b4d0b50ad2435d64cb69bd06987 100644 (file)
@@ -50,6 +50,9 @@ config BR2_PACKAGE_BOOST_LAYOUT
        default "tagged" if BR2_PACKAGE_BOOST_LAYOUT_TAGGED
        default "versioned" if BR2_PACKAGE_BOOST_LAYOUT_VERSIONED
 
+config BR2_PACKAGE_BOOST_ATOMIC
+       bool "boost-atomic"
+
 config BR2_PACKAGE_BOOST_CHRONO
        bool "boost-chrono"
 
index 7b56827bf1b4219d2fc55a0b904deda507005978..70160da4de01c97a909b2ef3480fce62d1a6b0dc 100644 (file)
@@ -23,11 +23,11 @@ HOST_BOOST_FLAGS = --without-icu \
        iostreams locale log math mpi program_options python random regex \
        serialization signals system test thread timer wave)
 
-# atomic library compile only with upstream version, wait for next release
 # coroutine breaks on some weak toolchains and it's new for 1.54+
 # log breaks with some toolchain combinations and it's new for 1.54+
-BOOST_WITHOUT_FLAGS = atomic coroutine log
+BOOST_WITHOUT_FLAGS = coroutine log
 
+BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_ATOMIC),,atomic)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CHRONO),,chrono)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CONTEXT),,context)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_DATE_TIME),,date_time)